summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndy Tai <atai@atai.org>2023-03-25 03:19:12 -0700
committerChristopher Baines <mail@cbaines.net>2023-06-03 12:16:17 +0100
commit9cf6833033a4c4dd821dcc7a886fcffb83a34185 (patch)
treee406264f441834b5e9f5127d7c32fd9fa87973a7 /gnu
parent76b7c50645cfba9554af9c80768765c5b714b893 (diff)
downloadguix-9cf6833033a4c4dd821dcc7a886fcffb83a34185.tar.gz
gnu: Remove obs-spectralizer.
As project no longer developed and not building with current obs.

* gnu/packages/video.scm (obs-spectralizer): Remove variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm31
1 files changed, 0 insertions, 31 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index ab19c2dd8c..3b6af31b76 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3475,37 +3475,6 @@ and JACK.")
     (home-page "https://obsproject.com")
     (license license:gpl2+)))
 
-(define-public obs-spectralizer
-  (package
-    (name "obs-spectralizer")
-    (version "1.3.3")
-    (source
-      (origin
-        (method git-fetch)
-        (uri (git-reference
-              (url "https://github.com/univrsal/spectralizer")
-              (commit (string-append "v" version))))
-        (file-name (git-file-name name version))
-
-        ;; Remove bundled Windows DLLs.
-        (snippet '(delete-file-recursively "fftw3"))
-        (modules '((guix build utils)))
-
-        (sha256
-         (base32
-          "0q75cnyqydpvfda51zm9gxqj3wqr99ad0lxzjhw0ld67qvj1ag6i"))))
-    (build-system cmake-build-system)
-    (arguments
-     `(#:tests? #f
-       #:configure-flags
-       (list "-DGLOBAL_INSTALLATION=ON" "-DUSE_CMAKE_LIBDIR=ON")))
-    (inputs (list obs fftw))
-    (home-page "https://github.com/univrsal/spectralizer")
-    (synopsis "OBS plugin for audio visualization")
-    (description "This OBS plugins allows you to vizualize MPD and internal
-OBS audio sources.")
-    (license license:gpl2)))
-
 (define-public obs-websocket
   (package
     (name "obs-websocket")