summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2022-06-19 21:18:02 +0200
committerAndreas Enge <andreas@enge.fr>2022-06-19 21:19:59 +0200
commita0500442557e2e7f0a138b6079df51290e3016dd (patch)
tree6a797e1c6d0cf0d9c1ebcca9dc4a4d0f3f0797fa /gnu
parent0d461393e444a993a469b521d4cf46dee9e2767e (diff)
downloadguix-a0500442557e2e7f0a138b6079df51290e3016dd.tar.gz
gnu: Add texlive-floatflt.
* gnu/packages/tex.scm (texlive-floatflt): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 19 insertions, 1 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a7b62150f8..de0a6d347c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015, 2016 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2014, 2015, 2016, 2022 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
@@ -10819,6 +10819,24 @@ pdfLaTeX: it provides two style files, @file{InriaSerif.sty} and
 their associated files.  These were created using autoinst.")
     (license (list license:lppl license:silofl1.1))))
 
+(define-public texlive-floatflt
+  (package
+    (inherit (simple-texlive-package
+              "texlive-floatflt"
+              (list "doc/latex/floatflt/"
+                    "source/latex/floatflt/"
+                    "tex/latex/floatflt/")
+              (base32
+               "1piy8ajbbcadsjwp0mhlgxm2ggggnb5sn75arfs5fxiaqrwd572j")
+              #:trivial? #t))
+    (home-page "https://ctan.org/macros/latex/contrib/floatflt")
+    (synopsis "Wrap text around floats")
+    (description
+     "The package can float text around figures and tables which do not
+span the full width of a page; it improves upon floatfig, and allows
+tables and figures to be set left/right or alternating on even/odd pages.")
+    (license license:lppl1.3+)))
+
 (define-public bibtool
   (package
     (name "bibtool")