summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-03-12 13:47:59 -0500
committerLeo Famulari <leo@famulari.name>2021-04-16 16:57:27 -0400
commita456b09c43b2505edfbd3c16c4130af4b72a30e2 (patch)
tree92ae0aa6c7ee503fa924302bc1b8f9399205841c /gnu
parent0cb4032f9a799e5b1a4f35b7a1881c1b69104466 (diff)
downloadguix-a456b09c43b2505edfbd3c16c4130af4b72a30e2.tar.gz
gnu: gdk-pixbuf: Absorb grafted replacement.
* gnu/packages/gtk.scm (gdk-pixbuf)[source]: Use
gdk-pixbuf-CVE-2020-29385.patch.
[replacement]: Remove field.
(gdk-pixbuf/fixed): Remove variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gtk.scm11
1 files changed, 1 insertions, 10 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index bffc9e0298..16efb072a3 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -567,12 +567,12 @@ highlighting and other features typical of a source code editor.")
   (package
    (name "gdk-pixbuf")
    (version "2.40.0")
-   (replacement gdk-pixbuf/fixed)
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnome/sources/" name "/"
                                 (version-major+minor version)  "/"
                                 name "-" version ".tar.xz"))
+            (patches (search-patches "gdk-pixbuf-CVE-2020-29385.patch"))
             (sha256
              (base32
               "1rnlx9yfw970maxi2x6niaxmih5la11q1ilr7gzshz2kk585k0hm"))))
@@ -624,15 +624,6 @@ in the GNOME project.")
    (license license:lgpl2.0+)
    (home-page "https://developer.gnome.org/gdk-pixbuf/")))
 
-(define gdk-pixbuf/fixed
-  (package
-    (inherit gdk-pixbuf)
-    (source (origin
-              (inherit (package-source gdk-pixbuf))
-              (patches
-               (append (search-patches "gdk-pixbuf-CVE-2020-29385.patch")
-                       (origin-patches (package-source gdk-pixbuf))))))))
-
 ;; To build gdk-pixbuf with SVG support, we need librsvg, and librsvg depends
 ;; on gdk-pixbuf, so this new varibale.  Also, librsvg adds 90MiB to the
 ;; closure size.