summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-01-07 14:04:08 +0100
committerMarius Bakke <marius@gnu.org>2023-01-07 21:04:26 +0100
commita47c475678c3647be918ebc97cced1e8a2306993 (patch)
tree17855b5e32570816638464cdb7e443a6c5d9d0c5 /gnu
parent7f9672660733c0e1bda2bf4761cc0ae443ece824 (diff)
downloadguix-a47c475678c3647be918ebc97cced1e8a2306993.tar.gz
gnu: python-setuptools: Add 57.5.0.
* gnu/packages/python-build.scm (python-setuptools-57): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-build.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index 716108df2b..17f8892c05 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -2,7 +2,7 @@
 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2015, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020, 2023 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;; Copyright © 2018, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -101,6 +101,18 @@ facilitate packaging Python projects, where packaging includes:
                    license:asl2.0       ;packaging is dual ASL2/BSD-2
                    license:bsd-2))))
 
+;; This is the last version with use_2to3 support.
+(define-public python-setuptools-57
+  (package
+    (inherit python-setuptools)
+    (version "57.5.0")
+    (source (origin
+              (inherit (package-source python-setuptools))
+              (uri (pypi-uri "setuptools" version))
+              (sha256
+               (base32
+                "091sp8lrin7qllrhhx7y0iiv5gdb1d3l8a1ip5knk77ma1njdlyr"))))))
+
 (define-public python-wheel
   (package
     (name "python-wheel")