summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-11-17 02:24:46 +0100
committerMarius Bakke <marius@gnu.org>2022-11-17 02:28:32 +0100
commitabf214cda01d668837a6432370ebd5382ad1612e (patch)
tree8b16f05e6e5ec009e05330361229a76ca1cb34eb /gnu
parent0081807e161a8632ae2bddbcefc040d6992134c3 (diff)
downloadguix-abf214cda01d668837a6432370ebd5382ad1612e.tar.gz
gnu: crc32c: Fix build on x86_64-linux.
* gnu/packages/cpp.scm (crc32c)[arguments]: Remove #:phases.  The check is for
SSE support in the compiler, not the build machine; and the runtime code tests
for SSE availability on the CPU before enabling the SSE code path.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cpp.scm8
1 files changed, 1 insertions, 7 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index c1e98b771d..210c76e482 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1976,13 +1976,7 @@ std::wstring, etc).")
                                       "-DCRC32C_BUILD_TESTS="
                                       ;; TODO: perhaps infer #:tests?
                                       (if #$(%current-target-system)
-                                          "OFF" "ON")))
-           #:phases
-           #~(modify-phases %standard-phases
-               (add-after 'unpack 'make-reproducible
-                 (lambda _
-                   (substitute* "CMakeLists.txt"
-                     (("if\\(HAVE_SSE42\\)") "if(FALSE)")))))))
+                                          "OFF" "ON")))))
     (native-inputs (list googletest))
     (home-page "https://github.com/google/crc32c")
     (synopsis "Cyclic redundancy check")