summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEric Dvorsak <eric@dvorsak.fr>2015-08-17 22:06:04 +0200
committerEric Bavier <bavier@member.fsf.org>2015-08-23 11:28:16 -0500
commitbda2ded6b665c1c40d798a523a4163c9295d16a4 (patch)
treea3b9d4f3e4a0e3a805a5cd61583baf633f3695dc /gnu
parent94a3d8fd6b11d750ce35cf44dabd4f8c6ac1d52b (diff)
downloadguix-bda2ded6b665c1c40d798a523a4163c9295d16a4.tar.gz
gnu: Add i3-wm.
* gnu/packages/wm.scm: New file.
* gnu-system.am (GNU_SYSTEM_MODULES): Add it.

Signed-off-by: Eric Bavier <bavier@member.fsf.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/wm.scm87
1 files changed, 87 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
new file mode 100644
index 0000000000..50c5f6f1c6
--- /dev/null
+++ b/gnu/packages/wm.scm
@@ -0,0 +1,87 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages wm)
+  #:use-module (guix licenses)
+  #:use-module (guix packages)
+  #:use-module (gnu packages linux)
+  #:use-module (guix build-system gnu)
+  #:use-module (gnu packages base)
+  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages perl)
+  #:use-module (gnu packages xorg)
+  #:use-module (gnu packages xdisorg)
+  #:use-module (gnu packages qt)
+  #:use-module (gnu packages asciidoc)
+  #:use-module (gnu packages xml)
+  #:use-module (gnu packages m4)
+  #:use-module (gnu packages docbook)
+  #:use-module (gnu packages pcre)
+  #:use-module (gnu packages gtk)
+  #:use-module (gnu packages libevent)
+  #:use-module (gnu packages maths)
+  #:use-module (gnu packages web)
+  #:use-module (guix download)
+  #:use-module (guix git-download))
+
+(define-public i3-wm
+  (package
+    (name "i3-wm")
+    (version "4.10.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://i3wm.org/downloads/i3-"
+                                  version ".tar.bz2"))
+              (sha256
+               (base32
+                "1lq7h4w7m0hi31iva8g7yf1sc11ispnknxjdaj9agld4smxqb44j"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:make-flags (list "CC=gcc" (string-append "PREFIX=" %output))
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure))
+       #:tests? #f)) ; no test suite
+    (inputs
+     `(("libxcb" ,libxcb)
+       ("xcb-util" ,xcb-util)
+       ("xcb-util-cursor" ,xcb-util-cursor)
+       ("xcb-util-keysyms" ,xcb-util-keysyms)
+       ("xcb-util-wm" ,xcb-util-wm)
+       ("libxkbcommon" ,libxkbcommon)
+       ("libev" ,libev)
+       ("libyajl" ,libyajl)
+       ("asciidoc" ,asciidoc)
+       ("xmlto" ,xmlto)
+       ("perl-pod-simple" ,perl-pod-simple)
+       ("docbook-xml" ,docbook-xml)
+       ("libx11" ,libx11)
+       ("pcre" ,pcre)
+       ("startup-notification" ,startup-notification)
+       ("pango" ,pango)
+       ("cairo" ,cairo)))
+    (native-inputs
+     `(("which" ,which)
+       ("perl" ,perl)
+       ("pkg-config" ,pkg-config)))
+    (home-page "http://i3wm.org/")
+    (synopsis "Improved tiling window manager")
+    (description "i3 is a tiling window manager, completely written
+from scratch.  i3 is primarily targeted at advanced users and
+developers.")
+    (license bsd-3)))