summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-24 23:47:08 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 20:16:05 -0400
commitbf23e8518fe62a2c3f2fe77444cce98f0d4e6bbd (patch)
tree80aca8b719b5e58431fb6115f1d9d2ef9d6c3839 /gnu
parentd624cd4c842a0e47ed3670ecb2a65b69cdccea63 (diff)
downloadguix-bf23e8518fe62a2c3f2fe77444cce98f0d4e6bbd.tar.gz
gnu: ffmpeg: Update to 6.0.
* gnu/packages/video.scm (ffmpeg): Update to 6.0.
(ffmpeg-5): New variable.
* gnu/packages/gnuzilla.scm (icecat-minimal) [inputs]: Replace ffmpeg with
ffmpeg-5.
* gnu/packages/gnuzilla.scm (icedove-minimal): Likewise.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnuzilla.scm11
-rw-r--r--gnu/packages/video.scm22
2 files changed, 24 insertions, 9 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 253b8c285c..475c2b5a38 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -706,9 +706,11 @@ variable defined below.  It requires guile-json to be installed."
            libxcomposite
            libxt
            libffi
-           ffmpeg
+           ;; Support for FFmpeg 6 was only added in version 112 (see:
+           ;; https://bugzilla.mozilla.org/show_bug.cgi?id=1819374).
+           ffmpeg-5
            libvpx
-           icu4c-71  ; TODO: Change to 'icu4c' when its version is >= 71.
+           icu4c-71       ;TODO: Change to 'icu4c' when its version is >= 71.
            pixman
            pulseaudio
            mesa
@@ -964,7 +966,7 @@ variable defined below.  It requires guile-json to be installed."
               ;; complain that it's not able to change Cargo.lock.
               ;; https://bugzilla.mozilla.org/show_bug.cgi?id=1726373
               (substitute* "build/RunCbindgen.py"
-                           (("\"--frozen\",") ""))))
+                (("\"--frozen\",") ""))))
           (delete 'bootstrap)
           (replace 'configure
             ;; configure does not work followed by both "SHELL=..." and
@@ -1492,7 +1494,8 @@ ca495991b7852b855"))
            cairo
            cups
            dbus-glib
-           ffmpeg
+           ;; Support for FFmpeg 6 was only added in version 112 (see:
+           ;; https://bugzilla.mozilla.org/show_bug.cgi?id=1819374).
            freetype
            gdk-pixbuf
            glib
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 064ebb07d3..f0f0683a1a 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1579,14 +1579,14 @@ operate properly.")
 (define-public ffmpeg
   (package
     (name "ffmpeg")
-    (version "5.1.2")
+    (version "6.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://ffmpeg.org/releases/ffmpeg-"
                                   version ".tar.xz"))
               (sha256
                (base32
-                "1p7kxr0f9f9d0pyyxq9ciaj9ch2drmcw5p9jk22j111ccrnp17k1"))))
+                "10kh2f4y4isfqj4xpcqqnzk611jh89ywcjyjnq9c2jcv5p18ggjp"))))
     (build-system gnu-build-system)
     (inputs
      (append
@@ -1728,8 +1728,8 @@ operate properly.")
          "--disable-static"
 
          #$@(if (target-riscv64?)
-              '("--extra-cflags=-fPIC")
-              '())
+                '("--extra-cflags=-fPIC")
+                '())
 
          ;; Runtime cpu detection is not implemented on
          ;; MIPS, so we disable some features.
@@ -1770,9 +1770,21 @@ convert and stream audio and video.  It includes the libavcodec
 audio/video codec library.")
     (license license:gpl2+)))
 
-(define-public ffmpeg-4
+(define-public ffmpeg-5
   (package
     (inherit ffmpeg)
+    (version "5.1.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://ffmpeg.org/releases/ffmpeg-"
+                                  version ".tar.xz"))
+              (sha256
+               (base32
+                "1p7kxr0f9f9d0pyyxq9ciaj9ch2drmcw5p9jk22j111ccrnp17k1"))))))
+
+(define-public ffmpeg-4
+  (package
+    (inherit ffmpeg-5)
     (version "4.4.2")
     (source (origin
              (method url-fetch)