summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <MadalinIonel.Patrascu@mdc-berlin.de>2020-02-25 14:52:25 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-02-25 15:37:27 +0100
commitc51c0033d00da046ff3fa573e99000b5b723cc05 (patch)
tree9279c143a9e355abaea03da3d31a8eafac86211a /gnu
parent1fc47a9b491bcc6d3a216592f00f71468a2c80f0 (diff)
downloadguix-c51c0033d00da046ff3fa573e99000b5b723cc05.tar.gz
gnu: Add r-bsgenome-hsapiens-ncbi-grch38.
* gnu/packages/bioconductor.scm (r-bsgenome-hsapiens-ncbi-grch38): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index e004560d58..e14f7bc93e 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -224,6 +224,30 @@ Finder (TRF mask).  Only the AGAPS and AMB masks are \"active\" by default.")
 1000genomes phase2 reference genome sequence (hs37d5), based on NCBI GRCh37.")
     (license license:artistic2.0)))
 
+(define-public r-bsgenome-hsapiens-ncbi-grch38
+  (package
+    (name "r-bsgenome-hsapiens-ncbi-grch38")
+    (version "1.3.1000")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "BSgenome.Hsapiens.NCBI.GRCh38"
+                              version 'annotation))
+       (sha256
+        (base32
+         "0y75qdq578fh6420vbvsbwmdw8jvr3g06qli2h3vj3pxmjykh9c1"))))
+    (properties `((upstream-name . "BSgenome.Hsapiens.NCBI.GRCh38")))
+    (build-system r-build-system)
+    (propagated-inputs `(("r-bsgenome" ,r-bsgenome)))
+    (home-page
+     "https://bioconductor.org/packages/release/data/annotation/html/\
+BSgenome.Hsapiens.NCBI.GRCh38.html")
+    (synopsis "Full genome sequences for Homo sapiens (GRCh38)")
+    (description
+     "This package provides full genome sequences for Homo sapiens (Human) as
+provided by NCBI (GRCh38, 2013-12-17) and stored in Biostrings objects.")
+    (license license:artistic2.0)))
+
 (define-public r-bsgenome-hsapiens-ucsc-hg19-masked
   (package
     (name "r-bsgenome-hsapiens-ucsc-hg19-masked")