summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-12 12:04:53 +0200
committerMarius Bakke <marius@gnu.org>2022-09-09 17:03:56 +0200
commitc5dd6e5d400dbc582fc0bf4a3ed7034f45ab6e71 (patch)
tree656873e7358d8b90a142ed45d0a8e4a4ac9cde54 /gnu
parent9912024c34e49d954cc50bcf62edb078e28938e8 (diff)
downloadguix-c5dd6e5d400dbc582fc0bf4a3ed7034f45ab6e71.tar.gz
gnu: python-pytest: Update to 7.1.3.
* gnu/packages/check.scm (python-pytest): Update to 7.1.3.
[native-inputs]: Remove PYTHON-MOCK and PYTHON-TOML.
[propagated-inputs]: Remove PYTHON-MORE-ITERTOOLS, PYTHON-SIX-BOOTSTRAP,
PYTHON-TOML, and PYTHON-WCWIDTH.  Add PYTHON-TOMLI.
(python-pytest-bootstrap)[native-inputs]: Replace PYTHON-TOML with PYTHON-TOMLI.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/check.scm13
1 files changed, 4 insertions, 9 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 25643b462d..556198269b 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -973,14 +973,14 @@ standard library.")
 (define-public python-pytest
   (package
     (name "python-pytest")
-    (version "6.2.5")
+    (version "7.1.3")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pytest" version))
        (sha256
         (base32
-         "12cyi0lnyaq8sdqfnqlppd76gkw6zcg10gyih5knx9v611l3c6qk"))))
+         "0f8c31v5r2kgjixvy267n0nhc4xsy65g3n9lz1i1377z5pn5ydjg"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -1007,22 +1007,17 @@ standard library.")
     (propagated-inputs
      (list python-attrs-bootstrap
            python-iniconfig
-           python-more-itertools
            python-packaging-bootstrap
            python-pluggy
            python-py
-           python-six-bootstrap
-           python-toml
-           python-wcwidth))
+           python-tomli))
     (native-inputs
      (list ;; Tests need the "regular" bash since 'bash-final' lacks `compgen`.
            bash
            python-hypothesis
            python-nose
-           python-mock
            python-pytest-bootstrap
            python-setuptools-scm
-           python-toml
            python-xmlschema))
     (home-page "https://docs.pytest.org/en/latest/")
     (synopsis "Python testing library")
@@ -1039,7 +1034,7 @@ and many external plugins.")
     (inherit python-pytest)
     (name "python-pytest-bootstrap")
     (native-inputs (list python-iniconfig python-setuptools-scm
-                         python-toml))
+                         python-tomli))
     (arguments `(#:tests? #f))))
 
 (define-public python-pytest-assume