summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2021-05-26 16:21:13 +0200
committerRoel Janssen <roel@gnu.org>2021-05-26 16:21:13 +0200
commitc66248528707d1b8f9b81236b1220db98fb3b7e7 (patch)
treefc2e6707ceced42af16dc4f9bbfce472d7deedb8 /gnu
parentcd5d1df15292a1aa59caf4c9ee5efb6e1c3bebc8 (diff)
downloadguix-c66248528707d1b8f9b81236b1220db98fb3b7e7.tar.gz
gnu: Add r-depmixs4.
* gnu/packages/cran.scm (r-depmixs4): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 9f89d2f38f..bf793d286a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1130,6 +1130,29 @@ without affecting the current R process at all.  This package does exactly
 that.")
     (license license:expat)))
 
+(define-public r-depmixs4
+  (package
+    (name "r-depmixs4")
+    (version "1.5-0")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "depmixS4" version))
+              (sha256
+               (base32
+                "1pacvhw5m4fsk3ysbal50fdqbvlaz8ywyqp6bn1wh42wipqbb2i8"))))
+    (propagated-inputs
+     `(("r-nnet" ,r-nnet)
+       ("r-nlme" ,r-nlme)
+       ("r-mass" ,r-mass)
+       ("r-rsolnp" ,r-rsolnp)))
+    (build-system r-build-system)
+    (home-page "https://cran.r-project.org/web/packages/depmixS4/")
+    (synopsis "Dependent Mixture Models")
+    (description "This package fits latent (hidden) Markov models on mixed
+categorical and continuous (time series) data, otherwise known as dependent
+mixture models.")
+    (license license:gpl2+)))
+
 (define-public r-readxl
   (package
     (name "r-readxl")