summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-11-17 12:38:41 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-11-17 13:05:52 +0200
commitc8ae11e77557cd20b1c7fc780c20306083ad6405 (patch)
treec2c479d727ff404321bd260acd232a2bf8e13ae3 /gnu
parent08b6a17de95ba6d26a39218bebd16cc61873505a (diff)
downloadguix-c8ae11e77557cd20b1c7fc780c20306083ad6405.tar.gz
gnu: python-mistune-next: Update to 2.0.4.
* gnu/packages/python-xyz.scm (python-mistune-next): Update to 2.0.4.
[arguments]: Add custom 'check phase.
[native-inputs]: Remove python-nose, add python-pytest.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1758450c2f..7f0dc8fba0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11284,14 +11284,22 @@ Python.")
   (package
     (inherit python-mistune)
     (name "python-mistune-next")
-    (version "2.0.0rc1")
+    (version "2.0.4")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "mistune" version))
               (sha256
                (base32
-                "1nd7iav1ixh9hlj4hxn6lmpava88d86ys8rqm30wgvr7gjlxnas5"))))
-    (native-inputs (list python-nose))))
+                "024q9l6mgd37wa25w7dhskv1m3zsj5lf0w9cfyx7l9p2adhadq4y"))))
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'check
+            (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                (invoke "pytest" "-vv")))))))
+    (native-inputs (list python-pytest))))
 
 (define-public python-markdown
   (package