summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorkiasoc5 <kiasoc5@disroot.org>2022-11-15 21:00:17 -0500
committerChristopher Baines <mail@cbaines.net>2022-11-17 12:00:31 +0000
commitce4896e85dfc667959b46c29191961f8280a364b (patch)
tree4aca26c9804b5d322e737139b35b85d5c6aaa498 /gnu
parentb64a80258b8bef89f560f47bf84b71061c6127a6 (diff)
downloadguix-ce4896e85dfc667959b46c29191961f8280a364b.tar.gz
gnu: httpie: Update to 3.2.1.
* gnu/packages/python-web.scm (httpie): Update to 3.2.1.
[propagated-inputs]: Add python-rich.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index f7bbcc48a1..871062f697 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -953,14 +953,14 @@ other HTTP libraries.")
 (define-public httpie
   (package
     (name "httpie")
-    (version "3.1.0")
+    (version "3.2.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "httpie" version))
        (sha256
         (base32
-         "1npyfvrq0l56bil8rnpj78mav378mxx4zcqzq1jjx4aap1020jif"))))
+         "1v736y2h7lcyrnxs9y5sf4xwzgll7pc2s6r3ny929mm8lcn07h69"))))
     (build-system python-build-system)
     (arguments
      ;; The tests attempt to access external web servers, so we cannot run them.
@@ -973,6 +973,7 @@ other HTTP libraries.")
            python-pysocks
            python-charset-normalizer
            python-defusedxml
+           python-rich
            python-multidict))
     (home-page "https://httpie.io")
     (synopsis "cURL-like tool for humans")