summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2015-12-31 09:27:51 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-01-28 00:08:32 +1000
commitd114ceebaca88edc9716e6de9949ce20c11a342f (patch)
tree60da707d1bddfbe5dcd7546e55ac8d8326fded79 /gnu
parent5799aadde41ea576c158ddf027ea8d16f47c91ac (diff)
downloadguix-d114ceebaca88edc9716e6de9949ce20c11a342f.tar.gz
gnu: Add ruby-http-cookie.
* gnu/packages/ruby.scm (ruby-http-cookie): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index ed1bc6975f..97078741cb 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3374,6 +3374,45 @@ Suffix List.")
     (home-page "https://github.com/knu/ruby-domain_name")
     (license license:bsd-2)))
 
+(define-public ruby-http-cookie
+  (package
+    (name "ruby-http-cookie")
+    (version "1.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "http-cookie" version))
+       (sha256
+        (base32
+         "0cz2fdkngs3jc5w32a6xcl511hy03a7zdiy988jk1sf3bf5v3hdw"))))
+    (build-system ruby-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'add-dependency-to-bundler
+           (lambda _
+             ;; Fix NameError
+             (substitute* "Rakefile"
+               (("HTTP::Cookie::VERSION")
+                "Bundler::GemHelper.gemspec.version"))
+             #t)))))
+    (propagated-inputs
+     `(("ruby-domain-name" ,ruby-domain-name)))
+    (native-inputs
+     `(("rubysimplecov" ,ruby-simplecov)
+       ("bundler" ,bundler)
+       ("ruby-sqlite3" ,ruby-sqlite3)
+       ("ruby-test-unit" ,ruby-test-unit)))
+    (synopsis "Handle HTTP Cookies based on RFC 6265")
+    (description
+     "@code{HTTP::Cookie} is a Ruby library to handle HTTP Cookies based on
+RFC 6265.  It has been designed with security, standards compliance and
+compatibility in mind, to behave just the same as today's major web browsers.
+It has built-in support for the legacy @code{cookies.txt} and
+@code{cookies.sqlite} formats of Mozilla Firefox.")
+    (home-page "https://github.com/sparklemotion/http-cookie")
+    (license license:expat)))
+
 (define-public ruby-ansi
   (package
     (name "ruby-ansi")