summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2022-09-22 19:44:09 +0000
committerLudovic Courtès <ludo@gnu.org>2022-10-02 23:21:58 +0200
commitd1c3de6583e24135cdd1a72cf2f5ee758182d402 (patch)
treef1dd6748091aec91c1fb3343295ecc17f63f091d /gnu
parent35c92a63245ff214dbd7fe8910b6ef8a01280e18 (diff)
downloadguix-d1c3de6583e24135cdd1a72cf2f5ee758182d402.tar.gz
gnu: python-setools: Update to 4.4.0.
* gnu/packages/selinux.scm (python-setools): Update to 4.4.0.
[source, home-page]: Update url.
[inputs]: Add python-pyqt.
[native-inputs]: Add python-cython.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/selinux.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/selinux.scm b/gnu/packages/selinux.scm
index b4f074b695..d898b55129 100644
--- a/gnu/packages/selinux.scm
+++ b/gnu/packages/selinux.scm
@@ -42,6 +42,7 @@
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages qt)
   #:use-module (gnu packages swig)
   #:use-module (gnu packages xml))
 
@@ -305,16 +306,16 @@ based on required access.")
 (define-public python-setools
   (package
     (name "python-setools")
-    (version "4.1.1")
+    (version "4.4.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                    (url "https://github.com/TresysTechnology/setools")
+                    (url "https://github.com/SELinuxProject/setools")
                     (commit version)))
               (file-name (string-append name "-" version "-checkout"))
               (sha256
                (base32
-                "0459xxly6zzqc5azcwk3rbbcxvj60dq08f8z6xr05y7dsbb16cg6"))))
+                "1qvd5j6zwq4fmlahg45swjplhif2z89x7s6pnp07gvcp2fbqdsh5"))))
     (build-system python-build-system)
     (arguments
      `(#:tests? #f ; the test target causes a rebuild
@@ -339,10 +340,10 @@ based on required access.")
     (propagated-inputs
      (list python-networkx))
     (inputs
-     (list libsepol libselinux))
+     (list libsepol libselinux python-pyqt))
     (native-inputs
-     (list bison flex swig))
-    (home-page "https://github.com/TresysTechnology/setools")
+     (list bison flex python-cython swig))
+    (home-page "https://github.com/SELinuxProject/setools")
     (synopsis "Tools for SELinux policy analysis")
     (description "SETools is a collection of graphical tools, command-line
 tools, and libraries designed to facilitate SELinux policy analysis.")