summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorBrett Gilio <brettg@posteo.net>2019-12-09 15:34:23 -0600
committerBrett Gilio <brettg@posteo.net>2019-12-09 15:34:23 -0600
commitd6cf4c6e777747ec50e41cfd9d74efff065efe05 (patch)
treee43646cddbbdf635527c0125245728a29c79b7d5 /gnu
parentb657b23ffb05a8eb22f91fe05bdfcd140081d93a (diff)
downloadguix-d6cf4c6e777747ec50e41cfd9d74efff065efe05.tar.gz
gnu: python-jsonrpc-server: Update to 0.3.2.
* gnu/packages/python-xyz.scm (python-jsonrpc-server): Update to 0.3.2.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 244eb1842f..8e892f05ef 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3007,19 +3007,20 @@ Language (TOML) configuration files.")
 (define-public python-jsonrpc-server
   (package
     (name "python-jsonrpc-server")
-    (version "0.1.2")
+    (version "0.3.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "python-jsonrpc-server" version))
        (sha256
         (base32
-         "0m4ykpcdy52x37n1ikysp07j7p8ialcdvvvsrjp3545sn7iiid09"))))
+         "0ddgdp26dfxaz6isjbb12974b3rxavgsqrn2zrmck62cmipg5g05"))))
     (build-system python-build-system)
     (propagated-inputs
      `(("python-future" ,python-future)
        ("python-mock" ,python-mock)
-       ("python-pytest" ,python-pytest)))
+       ("python-pytest" ,python-pytest)
+       ("python-ujson" ,python-ujson)))
     (home-page
      "https://github.com/palantir/python-jsonrpc-server")
     (synopsis "JSON RPC 2.0 server library")