summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2021-05-26 16:25:06 +0200
committerRoel Janssen <roel@gnu.org>2021-05-26 16:25:06 +0200
commitd80cb98b86d1e060f325b364fc0d375eb9ad55fa (patch)
tree953ba70f7d2657e26452df5cb9d2e84025b0e244 /gnu
parentc66248528707d1b8f9b81236b1220db98fb3b7e7 (diff)
downloadguix-d80cb98b86d1e060f325b364fc0d375eb9ad55fa.tar.gz
gnu: Add r-rnmf.
* gnu/packages/cran.scm (r-rnmf): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index bf793d286a..4005bacc7b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -19761,6 +19761,31 @@ introduced in Panneton et al. (2006), ``Improved Long-Period Generators Based
 on Linear Recurrences Modulo 2'', ACM Transactions on Mathematical Software.")
     (license license:bsd-3)))
 
+(define-public r-rnmf
+  (package
+   (name "r-rnmf")
+   (version "0.5.0")
+   (source (origin
+            (method url-fetch)
+            (uri (cran-uri "rNMF" version))
+            (sha256
+             (base32
+              "1nz6h0j5ywdh48m0swmhp34hbkycd7n13rclrxaw85qi9wc42597"))))
+   (build-system r-build-system)
+   (propagated-inputs
+    `(("r-knitr" ,r-knitr)
+      ("r-nnls" ,r-nnls)))
+   (home-page "https://cran.r-project.org/web/packages/rNMF/")
+   (synopsis "Robust nonnegative matrix factorization")
+   (description
+    "This package provides an implementation of robust nonnegative matrix
+factorization (rNMF).  The rNMF algorithm decomposes a nonnegative high
+dimension data matrix into the product of two low rank nonnegative matrices,
+while detecting and trimming outliers.  The main function is @code{rnmf()}.
+The package also includes a visualization tool, @code{see()}, that arranges
+and prints vectorized images.")
+   (license license:gpl2+)))
+
 (define-public r-randtoolbox
   (package
     (name "r-randtoolbox")