summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-02-24 15:11:47 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-03-01 11:09:32 +0200
commitd8ea27820408551f1a5864dab5b14d6f368ded24 (patch)
tree40988e2cfcbe0ce11622667935902c0b986abb2d /gnu
parentfea1f275bce93642c4c67e5f53c882f0bbd984f3 (diff)
downloadguix-d8ea27820408551f1a5864dab5b14d6f368ded24.tar.gz
gnu: Add oxygen-icons.
* gnu/packages/kde-frameworks.scm (oxygen-icons): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-frameworks.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index ec637e55d1..2f49dc098a 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -91,3 +91,27 @@ lower level classes for interaction with the X Windowing System.")
     ;; Some source files mention lgpl2.0+, but the included license is
     ;; the lgpl2.1. Some source files are under non-copyleft licenses.
     (license license:lgpl2.1+)))
+
+(define-public oxygen-icons
+  (package
+    (name "oxygen-icons")
+    (version kde-frameworks-version)
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "http://download.kde.org/stable/frameworks/"
+                            (version-major+minor version) "/"
+                            name "5-"version ".tar.xz"))
+        (sha256
+         (base32
+          "09vfwcyidj3bl0qr4sq78bkc69zp9x8dwp8bsay5y05q8591dkg0"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)
+       ("qt" ,qt)))
+    (home-page "https://community.kde.org/Frameworks")
+    (synopsis "Oxygen provides the standard icon theme for the KDE desktop.")
+    (description "Oxygen icon theme for the KDE desktop")
+    (license license:lgpl3+)))