summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2022-09-22 19:44:06 +0000
committerLudovic Courtès <ludo@gnu.org>2022-10-02 23:21:38 +0200
commitdec74d456365ae2d57213cbf0d0a9fd726600cbe (patch)
tree0b7c21079ae372dda9142881ce8cd2c05c819d74 /gnu
parent2070ce84ec3a3c683ff63b984af5cd7a0e813c1c (diff)
downloadguix-dec74d456365ae2d57213cbf0d0a9fd726600cbe.tar.gz
gnu: Add python-jschema-to-python.
* gnu/packages/python-web.scm (python-jschema-to-python): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 09dbebf44c..2517201722 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -758,6 +758,25 @@ the CloudFormation spec and additional checks.  Includes checking valid values
 for resource properties and best practices.")
     (license license:expat)))
 
+(define-public python-jschema-to-python
+  (package
+    (name "python-jschema-to-python")
+    (version "1.2.3")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "jschema_to_python" version))
+              (sha256
+               (base32
+                "14cvaiwm56g0v6p7zviikaa5i9ln3yqy910jmp60hirhbpz19zvn"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-attrs python-jsonpickle python-pbr))
+    (native-inputs (list python-pytest))
+    (home-page "https://github.com/microsoft/jschema-to-python")
+    (synopsis "Generate Python classes from a JSON schema.")
+    (description "This package generates source code for Python classes from a
+@url{http://jschema.org,JSchema} JSON schema.")
+    (license license:expat)))
+
 (define-public python-falcon
   (package
     (name "python-falcon")