summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-01-22 11:37:51 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-01-22 11:47:44 +0200
commite2227b6adae0abdb9aa5b9995ccf89d38b2314d7 (patch)
tree30c30c44c6e2c72d673461e66d043874fbf03640 /gnu
parentdddd7a75fa27c7e315a50efebd0111a29acb6734 (diff)
downloadguix-e2227b6adae0abdb9aa5b9995ccf89d38b2314d7.tar.gz
gnu: python-isort: Update to 4.3.4.
* gnu/packages/python-xyz.scm (python-isort): Update to 4.3.4.
[source]: Use 'git-fetch'.
[properties]: New field.
(python2-isort)[native-inputs]: Add python2-futures.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 16 insertions, 9 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e1bf779e22..83753c55f0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11396,17 +11396,18 @@ builds partial trees by inspecting living objects.")
 (define-public python-isort
   (package
     (name "python-isort")
-    (version "4.2.5")
+    (version "4.3.4")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append
-             "https://github.com/timothycrosley/isort/archive/"
-             version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+              ;; Tests pass only from the Github sources
+              (url "https://github.com/timothycrosley/isort")
+              (commit version)))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "0zsrgkb0krn5476yncy5dd56k7dk34zqb4bnlvwy44ixgilyjmfh"))))
+         "1q0mlrpki5vjbgwxag5rghljjcfg7mvb0pbkwid80p0sqrxlm2p6"))))
     (build-system python-build-system)
     (native-inputs
      `(("python-mock" ,python-mock)
@@ -11417,10 +11418,16 @@ builds partial trees by inspecting living objects.")
 imports alphabetically, and automatically separated into sections.  It
 provides a command line utility, a python library and plugins for various
 editors.")
-    (license license:expat)))
+    (license license:expat)
+    (properties `((python2-variant . ,(delay python2-isort))))))
 
 (define-public python2-isort
-  (package-with-python2 python-isort))
+  (let ((base (package-with-python2
+               (strip-python2-variant python-isort))))
+    (package (inherit base)
+      (native-inputs
+       `(("python2-futures" ,python2-futures)
+         ,@(package-native-inputs base))))))
 
 (define-public python2-backports-functools-lru-cache
   (package