summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:25:31 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:07 +0200
commiteb9305733e52cadf550650baae2de7bed93ac1b0 (patch)
treeb702a5a72d4e393435c2073cadac69ae412a8fad /gnu
parent6e469344cc0d27a43ed6759cdd4f9d0f4e215a87 (diff)
downloadguix-eb9305733e52cadf550650baae2de7bed93ac1b0.tar.gz
gnu: emacs-htmlize: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-htmlize)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6afced216c..7c99b1455c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6633,14 +6633,13 @@ source file, @file{jl-encrypt.el}.")
     (version "1.53")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append
-             "https://github.com/hniksic/emacs-htmlize/archive/release/"
-             version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/hniksic/emacs-htmlize.git")
+             (commit (string-append "release/" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32
-         "1lzaf9m1qr9dhw4nn53g6wszk2vqw95gpsbrc3y85bams4cn24ga"))))
+        (base32 "0dr235c0z8is3pi5xdgqyqljg6px0b2aya6qb79zkyi477bmz4ip"))))
     (build-system emacs-build-system)
     (home-page "https://github.com/hniksic/emacs-htmlize")
     (synopsis "Convert buffer text and decorations to HTML")