summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-03-26 13:48:49 +0100
committerAndreas Enge <andreas@enge.fr>2014-03-26 13:48:49 +0100
commitee172b1a06e21fafe34410f285695bab010667b7 (patch)
tree5ca355c2f11939f556e8ea7ce68d976ac10f36cc /gnu
parent7216a041581fe2533241ed31ddeec039cc66dd0e (diff)
downloadguix-ee172b1a06e21fafe34410f285695bab010667b7.tar.gz
gnu: pari-gp: Upgrade to 2.7.0.
* gnu/packages/algebra.scm (pari-gp): Upgrade to 2.7.0.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/algebra.scm17
1 files changed, 5 insertions, 12 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 2bfb6be930..79808cc172 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -83,14 +83,14 @@ solve the shortest vector problem.")
 (define-public pari-gp
   (package
    (name "pari-gp")
-   (version "2.5.5")
+   (version "2.7.0")
    (source (origin
             (method url-fetch)
             (uri (string-append
                   "http://pari.math.u-bordeaux.fr/pub/pari/unix/pari-"
                   version ".tar.gz"))
             (sha256 (base32
-                     "058nw1fhggy7idii4f124ami521lv3izvngs9idfz964aks8cvvn"))))
+                     "1hk7lmq09crr9jvia8nxzhvbwf8mw62xk456i96jg8dljh0r9sgz"))))
    (build-system gnu-build-system)
    (inputs `(("gmp" ,gmp)
              ("perl" ,perl)
@@ -103,17 +103,10 @@ solve the shortest vector problem.")
       #:phases
       (alist-replace
        'configure
-       (lambda* (#:key inputs outputs #:allow-other-keys)
-         (let ((out (assoc-ref outputs "out"))
-               (readline (assoc-ref inputs "readline"))
-               (gmp (assoc-ref inputs "gmp")))
+       (lambda* (#:key outputs #:allow-other-keys)
+         (let ((out (assoc-ref outputs "out")))
            (zero?
-            (system* "./Configure"
-                     (string-append "--prefix=" out)
-                     (string-append "--with-readline=" readline)
-                     (string-append "--with-gmp=" gmp)))))
-       ;; FIXME: readline and gmp will be detected automatically in the next
-       ;; stable release
+            (system* "./Configure" (string-append "--prefix=" out)))))
        %standard-phases)))
    (synopsis "PARI/GP, a computer algebra system for number theory")
    (description