summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-05-18 14:11:16 -0400
committerLudovic Courtès <ludo@gnu.org>2022-05-22 01:07:56 +0200
commitf0b7c8dca0fd42481734f0c19df4fa41570ea446 (patch)
tree60b999921843de1d89b1dff49b36724033ca42a8 /gnu
parent4d50052cf3417c77d878a75c491151fc6eaa9efb (diff)
downloadguix-f0b7c8dca0fd42481734f0c19df4fa41570ea446.tar.gz
gnu: Add elm-justinmimbs-date.
* gnu/packages/elm.scm (elm-justinmimbs-date): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/elm.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/elm.scm b/gnu/packages/elm.scm
index 69e60cd3bd..e92a2e222f 100644
--- a/gnu/packages/elm.scm
+++ b/gnu/packages/elm.scm
@@ -643,3 +643,24 @@ format strings and internationalization of dates.")
     (description "This package enhances @code{elm/time} with extra utilities
 for working with POSIX times.")
     (license license:bsd-3)))
+
+(define-public elm-justinmimbs-date
+  (package
+    (name "elm-justinmimbs-date")
+    (version "4.0.1")
+    (source
+     (elm-package-origin
+      "justinmimbs/date"
+      version
+      (base32 "13mf97137f0yb3gx1mxbya2y70qciah4hp5bcnpj8166vgzb7l3l")))
+    (build-system elm-build-system)
+    (propagated-inputs
+     (list elm-time
+           elm-parser
+           elm-core))
+    (home-page "https://package.elm-lang.org/packages/justinmimbs/date/4.0.1")
+    (synopsis "Work with dates without times or zones in Elm")
+    (description
+     "This Elm package provides a simple @code{Date} type for working with
+dates without times or zones.")
+    (license license:bsd-3)))