summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-02 02:00:11 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-02 02:00:09 +0200
commitf2f40cdae5d16b9026fd36dc063ac7d3b94ad9c0 (patch)
treeea35f005f5bbdc3955e55788feeca5d5e0cc9165 /gnu
parentba20f088b99e2c4447b79664875045348e15b4c1 (diff)
downloadguix-f2f40cdae5d16b9026fd36dc063ac7d3b94ad9c0.tar.gz
gnu: gmime: Use G-expressions.
* gnu/packages/mail.scm (gmime)[arguments]:
Rewrite as G-expressions.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mail.scm40
1 files changed, 20 insertions, 20 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 16a30daff5..7fdbe1085e 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -771,6 +771,26 @@ It adds a large amount of new and improved features to mutt.")
        (sha256
         (base32 "0yiylbw9iy49hgj29czinv246hh5c18qv6qkvbdrmq9z5m00sp01"))))
     (build-system gnu-build-system)
+    (arguments
+     (list #:configure-flags
+           #~(list "--enable-gtk-doc=yes"
+                   "--enable-introspection=yes")
+           #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'patch-paths-in-tests
+                 (lambda _
+                   ;; The test programs run several programs using 'system' with
+                   ;; hard-coded paths.  Here we patch them all.
+                   ;; We use ISO-8859-1 here because test-iconv.c contains
+                   ;; raw byte sequences in several different encodings.
+                   (with-fluids ((%default-port-encoding #f))
+                     (substitute* (find-files "tests" "\\.c$")
+                       (("(system *\\(\")(/[^ ]*)" all pre prog-path)
+                        (let* ((base (basename prog-path))
+                               (prog (which base)))
+                          (string-append pre
+                                         (or prog (error "not found: "
+                                                         base))))))))))))
     (native-inputs
      (list autoconf
            automake
@@ -782,26 +802,6 @@ It adds a large amount of new and improved features to mutt.")
            vala
            which))                      ; to find libtool, &c.
     (inputs (list glib gpgme zlib))
-    (arguments
-     `(#:configure-flags
-         (list "--enable-gtk-doc=yes"
-               "--enable-introspection=yes")
-       #:phases
-       (modify-phases %standard-phases
-         (add-after
-          'unpack 'patch-paths-in-tests
-          (lambda _
-            ;; The test programs run several programs using 'system' with
-            ;; hard-coded paths.  Here we patch them all.
-            ;; We use ISO-8859-1 here because test-iconv.c contains
-            ;; raw byte sequences in several different encodings.
-            (with-fluids ((%default-port-encoding #f))
-              (substitute* (find-files "tests" "\\.c$")
-                (("(system *\\(\")(/[^ ]*)" all pre prog-path)
-                 (let* ((base (basename prog-path))
-                        (prog (which base)))
-                   (string-append pre
-                                  (or prog (error "not found: " base))))))))))))
     (home-page "http://spruce.sourceforge.net/gmime/")
     (synopsis "MIME message parser and creator library")
     (description