summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-04-26 13:51:43 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-04-26 13:52:51 +0200
commitf365d48909156ad754a2ade45375f45b54b06bbc (patch)
tree2ab22c9fac5e297053d5730dcaa35da8b8d5f41a /gnu
parentaccb9fe6ac5516e4c575f95a3b2ed373d078e887 (diff)
downloadguix-f365d48909156ad754a2ade45375f45b54b06bbc.tar.gz
gnu: python-pyside-2: Propagate python-shiboken-2.
Importing PySide2 failed, because shiboken was not propagated. Testcase:

> guix environment --ad-hoc python python-pyside-2 -- python -c 'import PySide2'
PySide2/__init__.py: Unable to import shiboken2 from , /gnu/store/vpniba85hhzb2270hki61z0d2kfvb64l-profile/lib/python3.8/site-packages, /usr/lib/python38.zip, /usr/lib/python3.8, /usr/lib/python3.8/lib-dynload, /usr/lib/python3.8/site-packages
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/gnu/store/vpniba85hhzb2270hki61z0d2kfvb64l-profile/lib/python3.8/site-packages/PySide2/__init__.py", line 91, in <module>
    _setupQtDirectories()
  File "/gnu/store/vpniba85hhzb2270hki61z0d2kfvb64l-profile/lib/python3.8/site-packages/PySide2/__init__.py", line 57, in _setupQtDirectories
    import shiboken2
ModuleNotFoundError: No module named 'shiboken2'

* gnu/packages/qt.scm (python-pyside-2) [native-inputs]: Move from here…
[propagated-inputs]: …to here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/qt.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index c89d85884e..b206deaeba 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2687,9 +2687,10 @@ color-related widgets.")
        ("qtwebsockets" ,qtwebsockets)
        ("qtx11extras" ,qtx11extras)
        ("qtxmlpatterns" ,qtxmlpatterns)))
+    (propagated-inputs
+     `(("python-shiboken-2" ,python-shiboken-2)))
     (native-inputs
      `(("cmake" ,cmake-minimal)
-       ("python-shiboken-2" ,python-shiboken-2)
        ("python" ,python-wrapper)
        ("qttools" ,qttools)
        ("which" ,which)))