summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-22 17:53:02 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-07-18 20:56:06 +0300
commitfd2397549a5aab4a31b2baa585ca2e4b1409f277 (patch)
treebedd4620e57fe57c8dc7c46ab9143508b3679494 /gnu
parente7456c323c23b40908cc3bc763d8e180ddc25a6e (diff)
downloadguix-fd2397549a5aab4a31b2baa585ca2e4b1409f277.tar.gz
gnu: sequoia-sqv: Update to 1.1.0.
* gnu/packages/sequoia.scm (sequoia-sqv): Update to 1.1.0.
[arguments]: Don't skip tests. Remove phase adjusting crypto features.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/sequoia.scm17
1 files changed, 4 insertions, 13 deletions
diff --git a/gnu/packages/sequoia.scm b/gnu/packages/sequoia.scm
index cca8e37158..ba5a74f002 100644
--- a/gnu/packages/sequoia.scm
+++ b/gnu/packages/sequoia.scm
@@ -501,37 +501,28 @@ This Guix package is built to use the nettle cryptographic library.")
 (define-public sequoia-sqv
   (package
     (name "sequoia-sqv")
-    (version "1.0.0")
+    (version "1.1.0")
     (source
       (origin
         (method url-fetch)
         (uri (crate-uri "sequoia-sqv" version))
         (file-name (string-append name "-" version ".tar.gz"))
         (sha256
-          (base32 "0nrfjn64fm038x5dssipf7jxi27z741m5n5a7zsa9768zab1hr9d"))))
+          (base32 "0vzqahx7dk1wh2vp7lbzjgah8v7fqpvdf0dq0dydi9695ffm99lc"))))
     (build-system cargo-build-system)
     (inputs
      (list nettle openssl))
     (native-inputs
      (list clang pkg-config))
     (arguments
-     `(#:tests? #f  ;; tests require data-files not provided in the package
-       #:install-source? #f
+     `(#:install-source? #f
        #:cargo-inputs
        (("rust-anyhow" ,rust-anyhow-1)
         ("rust-chrono" ,rust-chrono-0.4)
         ("rust-clap" ,rust-clap-2)
-        ("rust-clap" ,rust-clap-2)
         ("rust-sequoia-openpgp" ,rust-sequoia-openpgp-1))
        #:cargo-development-inputs
-       (("rust-assert-cli" ,rust-assert-cli-0.6))
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'remove-other-crypto-features
-           (lambda _
-             (substitute* "Cargo.toml"
-               (("^crypto-cng =" line) (string-append "# " line))
-               (("^crypto-rust =" line) (string-append "# " line))))))))
+       (("rust-assert-cli" ,rust-assert-cli-0.6))))
     (home-page "https://sequoia-pgp.org/")
     (synopsis "Simple OpenPGP signature verification program")
     (description "@code{sqv} verifies detached OpenPGP signatures.  It is a