summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-26 01:02:30 +0200
committerMarius Bakke <marius@gnu.org>2022-06-26 12:06:28 +0200
commitfdd4eb53731ba89b8c434fdd88b82301c0e83aa7 (patch)
treea5653698c2268c15637e6e490a2bb159c42ec4c1 /gnu
parent7dfa2ff7804b4d4ffb4c256c5aaea92b2487b369 (diff)
downloadguix-fdd4eb53731ba89b8c434fdd88b82301c0e83aa7.tar.gz
gnu: jansson: Update to 2.14.
* gnu/packages/web.scm (jansson): Update to 2.14.
[source](uri): Change to new download location.
[arguments]: Add #:phases to fix a test failure.
[home-page]: Follow redirect.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm24
1 files changed, 17 insertions, 7 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 006ac26ace..294d8f5ab3 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1029,19 +1029,29 @@ libraries for working with JNLP applets.")
 (define-public jansson
   (package
     (name "jansson")
-    (version "2.13.1")
+    (version "2.14")
     (source (origin
              (method url-fetch)
-             (uri
-              (string-append "http://www.digip.org/jansson/releases/jansson-"
-                             version ".tar.bz2"))
+             (uri (string-append "https://github.com/akheron/jansson"
+                                 "/releases/download/v" version
+                                 "/jansson-" version ".tar.bz2"))
              (sha256
               (base32
-               "1g8h18vh8gyxlwfmvdivdp1siad26ywj5zr4j4avgdyjg7wa147f"))))
+               "1fdgji964mrrz19glx0zh91asji542fvybymvzk6rrbagkr5dagv"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:configure-flags '("--disable-static")))
-    (home-page "http://www.digip.org/jansson/")
+     (list
+      #:configure-flags #~'("--disable-static")
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'patch-tests
+            (lambda _
+              ;; Take a fix from upstream for testing with symbol versioning:
+              ;; https://github.com/akheron/jansson/pull/593
+              (substitute* "test/suites/api/check-exports"
+                (("(grep ' \\[DT\\] ' \\$test_log/symbols.*) \\| sort" _ cmd)
+                 (string-append cmd "| sed 's/@@libjansson.*//' | sort"))))))))
+    (home-page "https://github.com/akheron/jansson")
     (synopsis "JSON C library")
     (description
      "Jansson is a C library for encoding, decoding and manipulating JSON