summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-16 23:26:50 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-19 20:12:16 -0400
commitffef022d652e4a27c7629c38bb90b5a206d3f0fc (patch)
tree3bd63261e830a61ed1690988f25b77fe110b30bd /gnu
parentd477018b57d5b4c13b4dd35aa1c4ee1a00ca76e2 (diff)
downloadguix-ffef022d652e4a27c7629c38bb90b5a206d3f0fc.tar.gz
gnu: python-numpydoc: Update to 1.5.0.
* gnu/packages/python-xyz.scm (python-numpydoc): Update to 1.5.0.
[arguments]: Delete relax-requirements phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 2 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2de500b840..54c5f60682 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6900,23 +6900,18 @@ parse and apply unified diffs.  It has features such as:
 (define-public python-numpydoc
   (package
     (name "python-numpydoc")
-    (version "1.2.1")
+    (version "1.5.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "numpydoc" version))
        (sha256
         (base32
-         "1xjsli2fqks4iv3524v1d329siad7bbsi4kr174zvhsl1pnjds3w"))))
+         "0k2z3g4s3w39h1nd293542hl9qv55j29gcr3bkia0rr3ldsppnxh"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'relax-requirements
-           (lambda _
-             (substitute* "setup.py"
-               (("'Jinja2>=2.10,<3.1'")
-                "'Jinja2>=2.10'"))))
          (replace 'check
            (lambda* (#:key tests? #:allow-other-keys)
              (when tests?