summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2022-02-02 11:31:36 -0300
committerVinicius Monego <monego@posteo.net>2022-03-03 22:27:47 -0300
commit00a05e481d6dac46b34cc598c0394eb8e351c304 (patch)
tree560a4d0aa6f7da98a9af609c12ad65bb1392b47e /gnu
parent1af78ab5e80b98d1914b85709c60fa7f9782e1db (diff)
downloadguix-00a05e481d6dac46b34cc598c0394eb8e351c304.tar.gz
gnu: mlt: Wrap FREI0R_PATH and LADSPA_PATH.
* gnu/packages/video.scm (mlt)[arguments]: Use gexps. Add 'wrap-executable
phase.
[inputs]: Add bash-minimal.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm34
1 files changed, 25 insertions, 9 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 80d610a11b..023efd8852 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3221,18 +3221,34 @@ from sites like Twitch.tv and pipes them into a video player of choice.")
         (base32 "17d4gs46ca3n0qg6z69hl6mmllnqj2id8ccrv8fyz8c5zm55ghqm"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:tests? #f ;requires "Kwalify"
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'configure 'override-LDFLAGS
-           (lambda* (#:key outputs #:allow-other-keys)
-             (setenv "LDFLAGS"
-                     (string-append
-                      "-Wl,-rpath="
-                      (assoc-ref outputs "out") "/lib")))))))
+     (list
+      #:tests? #f                       ;requires "Kwalify"
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'configure 'override-LDFLAGS
+            (lambda _
+              (setenv "LDFLAGS"
+                      (string-append "-Wl,-rpath=" #$output "/lib"))))
+          (add-after 'install 'wrap-executable
+            (lambda _
+              (let* ((frei0r #$(this-package-input "frei0r-plugins"))
+                     (ladspa #$(this-package-input "ladspa"))
+                     ;; In MLT 7, 'melt' symlinks to 'melt-7'.  Try to keep
+                     ;; compatibility with MLT 6 where it's only 'melt'.
+                     (major #$(version-major version))
+                     (exec (if (file-exists?
+                                (string-append #$output "/bin/melt-" major))
+                               (string-append "melt-" major)
+                               "melt")))
+                (wrap-program (string-append #$output "/bin/" exec)
+                  `("FREI0R_PATH" ":" =
+                    (,(string-append frei0r "/lib/frei0r-1")))
+                  `("LADSPA_PATH" ":" =
+                    (,(string-append ladspa "/lib/ladspa"))))))))))
     (inputs
      (list alsa-lib
            `(,alsa-plugins "pulseaudio")
+           bash-minimal
            ffmpeg
            fftw
            frei0r-plugins