summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-09-24 14:43:53 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-09-26 00:33:01 +0200
commit020c4ef18e2a1ab877de803d697ca96acfa46624 (patch)
tree06bccaf92c153772767fadd8e400f93547ad94b1 /gnu
parenta0c9ba1d64be641192a22de3284aee2acb69214e (diff)
downloadguix-020c4ef18e2a1ab877de803d697ca96acfa46624.tar.gz
gnu: node: Delete expired tests.
* gnu/packages/node.scm (node)[arguments]: Delete tests for which the TLS
certificates have expired.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/node.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index d1de7a536c..de7d59c6b5 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -125,6 +125,14 @@
                          "test/sequential/test-child-process-emfile.js"
                          "test/sequential/test-benchmark-child-process.js"
                          "test/sequential/test-http-regr-gh-2928.js"))
+
+             ;; These tests have an expiry date: they depend on the validity of
+             ;; TLS certificates that are bundled with the source.  We want this
+             ;; package to be reproducible forever, so remove those.
+             ;; TODO: Regenerate certs instead.
+             (for-each delete-file
+                       '("test/parallel/test-tls-passphrase.js"
+                         "test/parallel/test-tls-server-verify.js"))
              #t))
          (replace 'configure
            ;; Node's configure script is actually a python script, so we can't