summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 17:31:50 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:52:25 -0400
commit0837d0aaf199f4826614f588342b871825273c25 (patch)
treee8100d903b934e2cd179bcf85ab128377f7c2aac /gnu
parent7ebb6b7b2b0806c605c88f80811a633cf153c2e5 (diff)
downloadguix-0837d0aaf199f4826614f588342b871825273c25.tar.gz
gnu: Remove python2-fastlmm.
* gnu/packages/machine-learning.scm (python2-fastlmm): Delete variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/machine-learning.scm32
1 files changed, 0 insertions, 32 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 02cd6b31aa..7b377c7d35 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1415,38 +1415,6 @@ such as online, hashing, allreduce, reductions, learning2search, active, and
 interactive learning.")
     (license license:bsd-3)))
 
-(define-public python2-fastlmm
-  (package
-    (name "python2-fastlmm")
-    (version "0.2.21")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "fastlmm" version ".zip"))
-       (sha256
-        (base32
-         "1q8c34rpmwkfy3r4d5172pzdkpfryj561897z9r3x22gq7813x1m"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:tests? #f ; some test files are missing
-       #:python ,python-2)) ; only Python 2.7 is supported
-    (propagated-inputs
-     (list python2-numpy
-           python2-scipy
-           python2-matplotlib
-           python2-pandas
-           python2-scikit-learn
-           python2-pysnptools))
-    (native-inputs
-     (list unzip python2-cython python2-mock python2-nose))
-    (home-page "http://research.microsoft.com/en-us/um/redmond/projects/mscompbio/fastlmm/")
-    (synopsis "Perform genome-wide association studies on large data sets")
-    (description
-     "FaST-LMM, which stands for Factored Spectrally Transformed Linear Mixed
-Models, is a program for performing both single-SNP and SNP-set genome-wide
-association studies (GWAS) on extremely large data sets.")
-    (license license:asl2.0)))
-
 (define-public python-hyperopt
   (package
     (name "python-hyperopt")