summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-10-27 23:14:47 +0100
committerChristopher Baines <mail@cbaines.net>2023-11-05 18:09:35 +0000
commit0d7e51d8ee94b0a56e48bc0d301ade965857f38a (patch)
tree26721f2a34017f33701d704a1a020c834c2a01ea /gnu
parenta8c1c9869093ca8b2cfae85f1c1186f6c8a4754a (diff)
downloadguix-0d7e51d8ee94b0a56e48bc0d301ade965857f38a.tar.gz
gnu: python-spherical-geometry: Enable tests.
* gnu/packages/astronomy.scm (python-spherical-geometry): Enable tests.
[build-system]: Switch to pyproject-build-system.
[arguments]{phases}: Add 'build-extensions phase.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index b69ba4d96a..f902c0da63 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2601,19 +2601,22 @@ of axis order, spatial projections, and spectral units that exist in the wild.
        (file-name (git-file-name name version))
        (sha256
         (base32 "0kzcncqir4v7nhk9lxj9gxr32p3krkaqa58y2i4kksgxxy24qw4z"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
      (list
-      ;; NOTE: (Sharlatan-20220523T231348+0100): Tests depends on old Python2
-      ;; libarry `sphere'
-      #:tests? #f
+      ;; XXX: Disable one failing test
+      ;; See https://github.com/spacetelescope/spherical_geometry/issues/252
+      #:test-flags #~(list "-k" "not test_overlap")
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'unpack 'preparations
             (lambda _
               (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version)
               ;; Use our own libraries in place of bundles.
-              (setenv "USE_SYSTEM_QD" "1"))))))
+              (setenv "USE_SYSTEM_QD" "1")))
+          (add-before 'check 'build-extensions
+            (lambda _
+              (invoke "python" "setup.py" "build_ext" "--inplace"))))))
     (native-inputs
      (list python-pytest
            python-setuptools-scm))