summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-21 00:21:19 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-21 00:25:07 -0500
commit20c64fc2e2e6029b41601e7b8e3bda319cb7e48e (patch)
tree1b1ebe2d8fb1c2f54542f8ee22566404c4285483 /gnu
parent4d6dcba9275e34650d49da4727a2aac4def341c5 (diff)
downloadguix-20c64fc2e2e6029b41601e7b8e3bda319cb7e48e.tar.gz
gnu: python-pillow: Add the python2-variant property.
This is apparently required to get the package-with-python2 package
transformer to pick up the correct python2-pillow package instead of
attempting to create a new one with the same version as python-pillow, as it
would happen for python2-matplotlib for example.

* gnu/packages/python-xyz.scm (python-pillow): Add python2-variant property.
(python2-pillow): Strip python2-variant property from inherited python-pillow,
and fix indentation.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b1363f8b24..c4c629b286 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5698,6 +5698,7 @@ efficient internal representation, and fairly powerful image processing
 capabilities.  The core image library is designed for fast access to data
 stored in a few basic pixel formats.  It should provide a solid foundation for
 a general image processing tool.")
+    (properties `((python2-variant . ,(delay python2-pillow))))
     (license (license:x11-style
               "http://www.pythonware.com/products/pil/license.htm"
               "The PIL Software License"))))
@@ -5705,16 +5706,16 @@ a general image processing tool.")
 (define-public python2-pillow
   (package-with-python2
    (package
-     (inherit python-pillow)
+     (inherit (strip-python2-variant python-pillow))
      ;; Version 6 is the last series with Python 2 support.
      (version "6.2.2")
      (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "Pillow" version))
-       (sha256
-        (base32
-         "0l5rv8jkdrb5q846v60v03mcq64yrhklidjkgwv6s1pda71g17yv")))))))
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "Pillow" version))
+        (sha256
+         (base32
+          "0l5rv8jkdrb5q846v60v03mcq64yrhklidjkgwv6s1pda71g17yv")))))))
 
 (define-public python-pillow-2.9
   (package