summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-01-06 21:06:16 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-01-06 21:35:03 +0200
commit26bd033fac082d4b7540d985e63a7b7917341268 (patch)
tree19284eee53b770d56087c91fe89642a7f1fc5e18 /gnu
parent0997d1fddd922c2c40e3f16fd35343e958ad0a2a (diff)
downloadguix-26bd033fac082d4b7540d985e63a7b7917341268.tar.gz
gnu: terminology: Update to 1.12.1.
* gnu/packages/enlightenment.scm (terminology): Update to 1.12.1.
[source]: Remove trailing #t.
[arguments]: Remove trailing #t from phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/enlightenment.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index 9253dec988..05f5a542e4 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -206,7 +206,7 @@ removable devices or support for multimedia.")
 (define-public terminology
   (package
     (name "terminology")
-    (version "1.11.0")
+    (version "1.12.1")
     (source (origin
               (method url-fetch)
               (uri
@@ -214,15 +214,14 @@ removable devices or support for multimedia.")
                               "terminology/terminology-" version ".tar.xz"))
               (sha256
                (base32
-                "0bbav27p1xni7kidgf3vn42bwsfrzds301k3f7c8dg7v5yyq9n2g"))
+                "1aasddf2343qj798b5s8qwif3lxj4pyjax6fa9sfi6if9icdkkpq"))
               (modules '((guix build utils)))
               ;; Remove the bundled fonts.
               (snippet
                '(begin
                   (delete-file-recursively "data/fonts")
                   (substitute* "data/meson.build"
-                    (("subdir\\('fonts'\\)") ""))
-                  #t))))
+                    (("subdir\\('fonts'\\)") ""))))))
     (build-system meson-build-system)
     (arguments
      `(#:configure-flags
@@ -234,7 +233,7 @@ removable devices or support for multimedia.")
        (modify-phases %standard-phases
          (add-after 'unpack 'set-home-directory
            ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
-           (lambda _ (setenv "HOME" "/tmp") #t))
+           (lambda _ (setenv "HOME" "/tmp")))
          (replace 'check
            (lambda _
              (with-directory-excursion
@@ -245,8 +244,7 @@ removable devices or support for multimedia.")
            (lambda* (#:key outputs #:allow-other-keys)
              ;; This file is not meant to be installed.
              (delete-file (string-append (assoc-ref outputs "out")
-                                         "/bin/tytest"))
-             #t)))))
+                                         "/bin/tytest")))))))
     (native-inputs
      `(("gettext" ,gettext-minimal)
        ("perl" ,perl)