summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorKyle Meyer <kyle@kyleam.com>2020-11-19 21:45:37 -0500
committerMathieu Othacehe <othacehe@gnu.org>2020-11-25 13:43:35 +0100
commit283b1becae2dd6da5fec4b180d0a24f1edfa5b60 (patch)
tree06172ca1bb182320a69705aac857efc392597cba /gnu
parent7d06279ef51401c93275882ac9e728561b969dd9 (diff)
downloadguix-283b1becae2dd6da5fec4b180d0a24f1edfa5b60.tar.gz
gnu: Add ghc-torrent.
* gnu/packages/haskell-xyz.scm (ghc-torrent): New variable.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index db8a60d3e7..5f37ae9db8 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -13823,6 +13823,28 @@ from a shell.  The @code{tldr} pages are a community effort to simplify the
 man pages with practical examples.")
     (license license:bsd-3)))
 
+(define-public ghc-torrent
+  (package
+    (name "ghc-torrent")
+    (version "10000.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/torrent/torrent-"
+             version ".tar.gz"))
+       (sha256
+        (base32 "0m7s0q7f8c7glxzqhf2j86ch5xhk6jnzwwsa4mkywag22119c290"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-bencode" ,ghc-bencode)
+       ("ghc-syb" ,ghc-syb)))
+    (home-page "https://hackage.haskell.org/package/torrent")
+    (synopsis "BitTorrent file parser and generator")
+    (description "This library provides support for parsing and generating
+BitTorrent files.")
+    (license license:bsd-3)))
+
 (define-public ghc-transformers
   (package
     (name "ghc-transformers")