summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-10-25 14:28:35 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-11-02 09:32:50 +0100
commit28ba576ff564c4cd4565a2b1b92607e5d509cd62 (patch)
tree7c2a37656b6c234d062aba2f9c2078a1aa38d445 /gnu
parent8216e89c8bdcee6e6bde27efe6620d45b4222318 (diff)
downloadguix-28ba576ff564c4cd4565a2b1b92607e5d509cd62.tar.gz
gnu: ghc-blaze-builder: Update to 0.4.2.2.
* gnu/packages/haskell-xyz.scm (ghc-blaze-builder): Update to 0.4.2.2.
[inputs]: Remove ghc-utf8-string; add ghc-bytestring-builder and ghc-semigroups.
[native-inputs]: Add ghc-hunit, ghc-quickcheck, ghc-test-framework,
ghc-test-framework-hunit, ghc-test-framework-quickcheck2, and
ghc-utf8-string.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-xyz.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 561080de36..67e5606968 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -1129,7 +1129,7 @@ functions.")
 (define-public ghc-blaze-builder
   (package
     (name "ghc-blaze-builder")
-    (version "0.4.2.1")
+    (version "0.4.2.2")
     (source
      (origin
        (method url-fetch)
@@ -1139,11 +1139,18 @@ functions.")
              ".tar.gz"))
        (sha256
         (base32
-         "01hbx82djckj2x74sk9kc79111djq7f2af3zl5i21y9zkjy8js3f"))))
+         "0rxg6vjr0ji6g1nngrqpl4k1q9w66fwkhld9cqm5yfhx0a69kp1c"))))
     (build-system haskell-build-system)
-    (arguments `(#:tests? #f))          ; FIXME: Missing test libraries.
     (inputs
-     `(("ghc-utf8-string" ,ghc-utf8-string)))
+     `(("ghc-bytestring-builder" ,ghc-bytestring-builder)
+       ("ghc-semigroups" ,ghc-semigroups)))
+    (native-inputs
+     `(("ghc-hunit" ,ghc-hunit)
+       ("ghc-quickcheck" ,ghc-quickcheck)
+       ("ghc-test-framework" ,ghc-test-framework)
+       ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
+       ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)
+       ("ghc-utf8-string" ,ghc-utf8-string)))
     (home-page "https://github.com/lpsmith/blaze-builder")
     (synopsis "Efficient buffered output")
     (description "This library provides an implementation of the older