summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2017-04-28 10:09:31 +0200
committerRoel Janssen <roel@gnu.org>2017-04-28 10:09:31 +0200
commit2abfc5b8279e07f9adbe30a55aacde99420a8c66 (patch)
treed1569d07d53a54f1ab37755d1c6457bc90a73b19 /gnu
parent833361a483d68a1888e4949e24bb79594739fd8a (diff)
downloadguix-2abfc5b8279e07f9adbe30a55aacde99420a8c66.tar.gz
gnu: Add r-bookdown.
* gnu/packages/bioinformatics.scm (r-bookdown): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 46e238f85d..4db91e4b3e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -6092,6 +6092,28 @@ categorize packages in a Bioconductor package repository according to keywords,
 also known as views, in a controlled vocabulary.")
     (license license:artistic2.0)))
 
+(define-public r-bookdown
+  (package
+  (name "r-bookdown")
+  (version "0.3")
+  (source (origin
+            (method url-fetch)
+            (uri (cran-uri "bookdown" version))
+            (sha256
+             (base32
+              "0r9bchzg7im6psc3jphvshzbidc5bv5xaih1qg7b5518jy4iyvb9"))))
+  (build-system r-build-system)
+  (propagated-inputs
+   `(("r-htmltools" ,r-htmltools)
+     ("r-knitr" ,r-knitr)
+     ("r-rmarkdown" ,r-rmarkdown)
+     ("r-yaml" ,r-yaml)))
+  (home-page "https://github.com/rstudio/bookdown")
+  (synopsis "Authoring books and technical documents with R markdown")
+  (description "This package provides output formats and utilities for
+authoring books and technical documents with R Markdown.")
+  (license license:gpl3)))
+
 (define-public r-biocstyle
   (package
    (name "r-biocstyle")