summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-11 12:00:38 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-17 14:00:16 +0200
commit3236599f50ebcb1c2355a3c9f687720fa2f54005 (patch)
tree0f20008bb7f69eced27b1b43b56d2e7d780aaeb2 /gnu
parentfedb80ee0e6527cb4e29380a4c2ffd343110287e (diff)
downloadguix-3236599f50ebcb1c2355a3c9f687720fa2f54005.tar.gz
gnu: Add texlive-latex-bigfoot.
* gnu/packages/tex.scm (texlive-latex-bigfoot): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ce29ba0296..c4314cde5d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1647,6 +1647,41 @@ make direct processing by LaTeX easier.  The package can be used either in
 conjunction with BibTeX or as a replacement for BibTeX.")
     (license license:lppl1.3+)))
 
+(define-public texlive-latex-bigfoot
+  (package
+    (name "texlive-latex-bigfoot")
+    (version (number->string %texlive-revision))
+    (source (origin
+              (method svn-fetch)
+              (uri (texlive-ref "latex" "bigfoot"))
+              (file-name (string-append name "-" version "-checkout"))
+              (sha256
+               (base32
+                "092g8alnsdwlgl1isdnqrr32l161994295kadr1n05d81xgj5wnv"))))
+    (build-system texlive-build-system)
+    (arguments
+     '(#:tex-directory "latex/bigfoot"
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'remove-generated-file
+           (lambda _
+             (for-each delete-file (find-files "." "\\.drv$"))
+             #t)))))
+    (home-page "http://www.ctan.org/pkg/bigfoot")
+    (synopsis "Footnotes for critical editions")
+    (description
+     "This package aims to provide a one-stop solution to requirements for
+footnotes.  It offers: Multiple footnote apparatus superior to that of
+@code{manyfoot}.  Footnotes can be formatted in separate paragraphs, or be run
+into a single paragraph (this choice may be selected per footnote series);
+Things you might have expected (such as @code{\\verb}-like material in
+footnotes, and color selections over page breaks) now work.  Note that the
+majority of the bigfoot package's interface is identical to that of
+@code{manyfoot}; users should seek information from that package's
+documentation.  The bigfoot bundle also provides the @code{perpage} and
+@code{suffix} packages.")
+    (license license:gpl2+)))
+
 (define-public texlive-latex-blindtext
   (package
     (name "texlive-latex-blindtext")