summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 21:20:10 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-19 20:33:52 +0200
commit3e5b21261ab92db6b02bfba0dbe53065e58b0fa0 (patch)
treefd1d9aa3a4cea86ba98ef533eb7c65d01df8a3aa /gnu
parente4681734f3fc0d449343a97609dfeffc53fb5c04 (diff)
downloadguix-3e5b21261ab92db6b02bfba0dbe53065e58b0fa0.tar.gz
gnu: Add texlive-biblatex-philosophy.
* gnu/packages/tex.scm (texlive-biblatex-philosophy): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm55
1 files changed, 55 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ce3c19e1c6..c36e7d368a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4297,6 +4297,61 @@ The bundle provides support for a wide variety of content types, including
 manuscripts, audiovisual resources, social media and legal references.")
     (license license:lppl1.3c)))
 
+(define-public texlive-biblatex-philosophy
+  (package
+    (name "texlive-biblatex-philosophy")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/biblatex-philosophy/"
+                   "source/latex/biblatex-philosophy/"
+                   "tex/latex/biblatex-philosophy/")
+             (base32
+              "05fapyb6wwyv4mwjhgg3gasvqkwpwd6jxv095hird9011n6drrzm")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (arguments (list #:tex-format "latex"))
+    (native-inputs
+     (list (texlive-updmap.cfg
+            (list texlive-biblatex
+                  texlive-cochineal
+                  texlive-csquotes
+                  texlive-etoolbox
+                  texlive-fontaxes
+                  texlive-fontsize
+                  texlive-guitlogo
+                  texlive-hologo
+                  texlive-hypdoc
+                  texlive-inconsolata
+                  texlive-libertine
+                  texlive-listings
+                  texlive-ltxdockit
+                  texlive-manfnt
+                  texlive-mdframed
+                  texlive-metalogo
+                  texlive-microtype
+                  texlive-needspace
+                  texlive-newtx
+                  texlive-parskip
+                  texlive-pgf
+                  texlive-sectsty
+                  texlive-upquote
+                  texlive-xcolor
+                  texlive-xkeyval
+                  texlive-xstring
+                  texlive-zref))))
+    (home-page "https://ctan.org/pkg/biblatex-philosophy")
+    (synopsis "Styles for using BibLaTeX for work in philosophy")
+    (description
+     "The bundle offers two styles --- @code{philosophy-classic} and
+@code{philosophy-modern} --- that facilitate the production of two different
+kinds of bibliography, based on the author-year style, with options and
+features to manage the information about the translation of foreign texts or
+their reprints.  Though the package's default settings are based on the
+conventions used in Italian publications, these styles can be used with every
+language recognized by Babel, possibly with some simple redefinitions.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-biblatex-phys
   (package
     (name "texlive-biblatex-phys")