summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-25 21:14:44 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-25 23:56:28 +0100
commit4c76af04e014ca001ae97369c0f1100f9c1cdcbf (patch)
treeda49b2d759ced460ad604ec814dd789b29a86de8 /gnu
parentfc14661c7b23d93d4fd3e2eacbbfc8dbe10807c5 (diff)
downloadguix-4c76af04e014ca001ae97369c0f1100f9c1cdcbf.tar.gz
gnu: libaudec: Update to 0.2.4.
* gnu/packages/audio.scm (libaudec): Update to 0.2.4.
[arguments]: Use a newer #:meson.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/audio.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 852b56e80f..d3090edf61 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -58,6 +58,7 @@
   #:use-module (gnu packages backup)
   #:use-module (gnu packages base)
   #:use-module (gnu packages bison)
+  #:use-module (gnu packages build-tools)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
@@ -4713,7 +4714,7 @@ in the package.")
 (define-public libaudec
   (package
     (name "libaudec")
-    (version "0.2.3")
+    (version "0.2.4")
     (source
       (origin
         (method git-fetch)
@@ -4723,11 +4724,13 @@ in the package.")
         (file-name (git-file-name name version))
         (sha256
           (base32
-            "04hw61db8wscj28qjyiaiafx8xl87njgmvqszxyhs4gmg8xgjip7"))))
+            "1570m2dfia17dbkhd2qhx8jjihrpm7g8nnyg6n4wif4vv229s7dz"))))
    (build-system meson-build-system)
    (arguments
-     ;; Compile tests.
-    `(#:configure-flags `("-Dtests=true")))
+    `(#:meson ,meson-0.55
+      #:configure-flags
+      ;; Build the tests.
+      `("-Dtests=true")))
    (inputs
     `(("libsamplerate" ,libsamplerate)
       ("libsndfile" ,libsndfile)))