summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-06-06 17:03:44 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-06-07 09:11:53 -0400
commit4e92098e85429ee5896251a164e5f3c8a6eb51ed (patch)
tree5b9629d5666af3917d6e825a6834ea8cf6245c13 /gnu
parent08063e55ba749466884d9ff16c44af71cb95812c (diff)
downloadguix-4e92098e85429ee5896251a164e5f3c8a6eb51ed.tar.gz
gnu: python-trezor-agent: Delete trailing #t and honor TESTS?.
* gnu/packages/finance.scm (python-trezor-agent)
[phases]: Delete trailing #t.
{check}: Honor TESTS?.  Delete extraneous add-installed-pythonpath call.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/finance.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 1b86f240dd..b02012a72c 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -875,14 +875,12 @@ the Monero GUI client.")
            ;; a built-in implementation supported in python-trezor-agent.
            (lambda _
              (substitute* "setup.py"
-               (("'backports.shutil_which>=3.5.1',") ""))
-             #t))
+               (("'backports.shutil_which>=3.5.1',") ""))))
          (delete 'check)
          (add-after 'install 'check
-           (lambda* (#:key outputs inputs #:allow-other-keys)
-             ;; Make installed package available for running the tests.
-             (add-installed-pythonpath inputs outputs)
-             (invoke "py.test"))))))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "pytest" "-v")))))))
     (propagated-inputs
      (list python-configargparse
            python-daemon