summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorCairn <cairn@pm.me>2023-06-15 17:52:50 +0000
committerLudovic Courtès <ludo@gnu.org>2023-06-24 16:56:16 +0200
commit5338f5eec0f94dd2b38938cafe8a71867c90c594 (patch)
tree7fb113558c49f3256f755cc360738b89015b8731 /gnu
parentf9f6f8d25ab00e41448ae6f89a42d63fd4a35baa (diff)
downloadguix-5338f5eec0f94dd2b38938cafe8a71867c90c594.tar.gz
gnu: Add ansilove.
* gnu/packages/image-processing.scm (ansilove): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/image-processing.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 7eaa0eed67..3a846cbe25 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -1763,3 +1763,28 @@ to images.")
 including ANSI (.ANS) and many others.  The library primarily serves to support
 the ansilove tool.")
     (license license:bsd-2)))
+
+(define-public ansilove
+  (package
+    (name "ansilove")
+    (version "4.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/ansilove/ansilove")
+                    (commit (string-append version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1h9r759krjl8wi68yxs1d46qfrx6v89a8vmmv3aqym8vn9x430kh"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     (list libansilove))
+    (home-page "https://www.ansilove.org/")
+    (synopsis "ANSI and ASCII art to PNG converter")
+    (description
+     "AnsiLove is an ANSI and ASCII art to PNG converter, allowing to convert
+ANSI and artscene-related file formats into PNG images, supporting ANSI (.ANS),
+PCBoard (.PCB), Binary (.BIN), Artworx (.ADF), iCE Draw (.IDF), Tundra (.TND)
+and XBin (.XB) formats.")
+    (license license:bsd-2)))