summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-04-06 12:04:24 -0500
committerEric Bavier <bavier@member.fsf.org>2015-04-19 19:48:47 -0500
commit55025bb516157db8a8e8dbd774fdd1bb1382e920 (patch)
tree929568a4ae8ca7b5d6d00e6adb854414c18e262e /gnu
parent08bf70953faa189a73335f97902ccf0b06d5a3e5 (diff)
downloadguix-55025bb516157db8a8e8dbd774fdd1bb1382e920.tar.gz
gnu: Add Email-MIME-ContentType.
* gnu/packages/mail.scm (perl-email-mime-contenttype): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mail.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 1121ea91c8..afa1f64ddb 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -689,4 +689,25 @@ objects found.  Alternatively you may construct objects manually.")
 identify a message uniquely.")
     (license (package-license perl))))
 
+(define-public perl-email-mime-contenttype
+  (package
+    (name "perl-email-mime-contenttype")
+    (version "1.017")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/R/RJ/RJBS/"
+                           "Email-MIME-ContentType-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1cl1l97lg690dh7i704hqi7yhxalq1chy7ylld5yc5v38jqa6gcn"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-capture-tiny" ,perl-capture-tiny)))
+    (home-page "http://search.cpan.org/dist/Email-MIME-ContentType")
+    (synopsis "Parse MIME Content-Type headers")
+    (description "Email::MIME::ContentType parses a MIME Content-Type
+header.")
+    (license (package-license perl))))
+
 ;;; mail.scm ends here