summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo G. Herdt <r.herdt@posteo.de>2023-06-21 19:27:32 +0000
committerAndrew Tropin <andrew@trop.in>2023-08-07 13:36:11 +0400
commit56667ee55cd7f3368cbff169352fe440f4f93da5 (patch)
tree5b244735f33f4cece40da6257ce2e4e4bb642613 /gnu
parent985638aea14720e16ed5fd94a0e1382a57dec7ac (diff)
downloadguix-56667ee55cd7f3368cbff169352fe440f4f93da5.tar.gz
gnu: guile-scheme-json-rpc: Update to 0.4.0.
* gnu/packages/guile-xyz.scm (guile-scheme-json-rpc): Update to 0.4.0.
[inputs]: Add guile-srfi-145, guile-srfi-180, remove guile-json-3.

Co-authored-by: Andrew Tropin <andrew@trop.in>
Signed-off-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/guile-xyz.scm53
1 files changed, 25 insertions, 28 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 53f5e08e6f..a350b6700e 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1054,36 +1054,33 @@ It has a nice, simple s-expression based syntax.")
     (inputs (list guile-2.2))))
 
 (define-public guile-scheme-json-rpc
-  (let ((commit "45ae6890f6619286f5679f88c094c88127b54c4a")
-        (revision "0")
-        (version "0.2.11"))
-    (package
-      (name "guile-scheme-json-rpc")
-      (version (git-version version revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://codeberg.org/rgherdt/scheme-json-rpc.git")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "0w4m8xx8yyj0rv0q57mjr8ja87l7yikscj33i3ck26wg7230ppa5"))))
-      (build-system gnu-build-system)
-      (arguments
-       `(#:phases (modify-phases %standard-phases
-                    (add-after 'unpack 'change-to-guile-dir
-                      (lambda _
-                        (chdir "guile"))))))
-      (inputs (list guile-3.0 guile-json-3))
-      (native-inputs (list pkg-config))
-      (synopsis "Library providing JSON-RPC capability in Scheme")
-      (description
-       "This library implements parts of the
+  (package
+    (name "guile-scheme-json-rpc")
+    (version "0.4.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://codeberg.org/rgherdt/scheme-json-rpc.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0jsampz2ahs18z6yh9b5l3lkj8ycnavs0vg9sjngdj3w3zvrdcvm"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'change-to-guile-dir
+                    (lambda _
+                      (chdir "guile"))))))
+    (inputs (list guile-3.0 guile-srfi-145 guile-srfi-180))
+    (native-inputs (list pkg-config))
+    (synopsis "Library providing JSON-RPC capability for Guile Scheme")
+    (description
+     "This library implements parts of the
 @uref{https://www.jsonrpc.org/specification,JSON-RPC specification}, allowing
 for calling methods on remote servers by exchanging JSON objects.")
-      (home-page "https://codeberg.org/rgherdt/scheme-json-rpc/")
-      (license license:expat))))
+    (home-page "https://codeberg.org/rgherdt/scheme-json-rpc/")
+    (license license:expat)))
 
 (define-public guile-squee
   (let ((commit "9f2609563fc53466e46d37c8d8d2fbcfce67b2ba")