summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-06-24 00:25:57 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-06-24 13:25:28 +0200
commit57945dd70c7acd5b7e14db75df101e1978ab4a00 (patch)
tree2e046ab50e0ee9d6d6c65222b43184bbb5d5f8fa /gnu
parent3b39f09fd99cd07543b904d11ea9b3463c38ecb7 (diff)
downloadguix-57945dd70c7acd5b7e14db75df101e1978ab4a00.tar.gz
gnu: znc: Switch back to Guix's googletest package.
* gnu/packages/messaging.scm (znc)[native-inputs]: Use the packaged
googletest's sources.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/check.scm2
-rw-r--r--gnu/packages/messaging.scm16
2 files changed, 1 insertions, 17 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index e19c3d4659..9bc5036cf6 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -478,8 +478,6 @@ test coverage and has a web user interface that will refresh automatically.")
     (home-page "https://github.com/smartystreets/goconvey")
     (license license:expat)))
 
-;; XXX When updating, check whether ZNC's GOOGLETEST-SOURCES can be
-;; switched back to simply using (PACKAGE-SOURCE ...).
 (define-public googletest
   (package
     (name "googletest")
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 8aeefa64e1..e4f150c817 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -517,21 +517,7 @@ compromised.")
                            "--with-gtest=googletest/googletest")
        #:test-target "test"))
     (native-inputs
-     `(("googletest-source"
-        ;; ZNC 1.7 needs a newer, unreleased googletest (a release is planned
-        ;; <https://github.com/google/googletest/issues/1583>, so don't update
-        ;; the public GOOGLETEST to an unstable version).  The commit is taken
-        ;; from ‘third_party/googletest’ in the ZNC git repository.
-        ,(let ((commit "9737e63c69e94ac5777caa0bc77c77d5206467f3"))
-           (origin
-             (method git-fetch)
-             (uri (git-reference
-                   (url "https://github.com/google/googletest")
-                   (commit commit)))
-             (file-name (git-file-name "googletest-for-znc" commit))
-             (sha256
-              (base32
-               "0ya36n8d62zbxk6p22yffgx43mqhx2fz41gqqwbpdshjryf3wvxj")))))
+     `(("googletest-source" ,(package-source googletest))
        ("pkg-config" ,pkg-config)
        ("perl" ,perl)
        ("python" ,python)))