summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2015-12-15 13:05:20 +0200
committerEfraim Flashner <efraim@flashner.co.il>2015-12-15 18:31:13 +0200
commit664e6c3a95521b3642160645f96aa0a0867ba918 (patch)
treee673b26ba8d909af075e9c0511260992d1fcea75 /gnu
parentba3cb5ab5c64076881880a26126daa2c57447bf9 (diff)
downloadguix-664e6c3a95521b3642160645f96aa0a0867ba918.tar.gz
gnu: python-keyring: Update to 5.7.1.
* gnu/packages/python.scm (python-keyring): Update to 5.7.1.
[source]: Change to pypi syntax.
[native-inputs]: Add python-setuptools-scm.
[arguments]: Remove argument to replace unpack with unzip.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm23
1 files changed, 6 insertions, 17 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b94dc1dbcc..fd8c4fc5c7 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -838,34 +838,23 @@ etc.).  The package is structured to make adding new modules easy.")
 (define-public python-keyring
   (package
     (name "python-keyring")
-    (version "3.8")
+    (version "5.7.1")
     (source
      (origin
       (method url-fetch)
-      (uri (string-append "https://pypi.python.org/packages/source/k/"
-                          "keyring/keyring-" version ".zip"))
+      (uri (pypi-uri "keyring" version))
       (sha256
        (base32
-        "1vxazfbcwggyfyramh55shkxs08skhpqrkm6lrrjnygnm8c1l2zg"))))
+        "1h7a1r9ick7wdd0xb5p63413nvjadna2xawrsvmklsl5ddhm5wrx"))))
     (build-system python-build-system)
     (native-inputs
-     `(("unzip" ,unzip)
-       ("python-setuptools" ,python-setuptools)
+     `(("python-setuptools" ,python-setuptools)
+       ("python-setuptools-scm" ,python-setuptools-scm)
        ("python-mock" ,python-mock)))
     (inputs
      `(("python-pycrypto" ,python-pycrypto)))
     (arguments
-     `(#:tests? #f                      ;TODO: tests require pytest
-       #:phases
-       (alist-replace
-        'unpack
-        (lambda _
-          (let ((unzip (string-append (assoc-ref %build-inputs "unzip")
-                                      "/bin/unzip"))
-                (source (assoc-ref %build-inputs "source")))
-            (and (zero? (system* unzip source))
-                 (chdir (string-append "keyring-" ,version)))))
-        %standard-phases)))
+     `(#:tests? #f))                      ;TODO: tests require pytest
     (home-page "http://bitbucket.org/kang/python-keyring-lib")
     (synopsis "Store and access your passwords safely")
     (description