summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-09 15:16:00 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-09 15:16:00 +0100
commit6c29b582160aee408f0079d0a13dd316374098b5 (patch)
tree8324b1015b5f6e22aa59a7bd9be41cec438d050e /gnu
parenta80f9a075172d0feccaaa4e7830d0a65a9aa23cd (diff)
downloadguix-6c29b582160aee408f0079d0a13dd316374098b5.tar.gz
gnu: emacs-theme-magic: Use new package style.
* gnu/packages/emacs-xyz.scm (emacs-theme-magic)[arguments]: Use
G-expressions.
<#:phases>: Use SEARCH-INPUT-FILE instead of ASSOC-REF.  Remove trailing #T.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm30
1 files changed, 16 insertions, 14 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f8af29fa79..92aebf2089 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1117,20 +1117,22 @@ then only the color of the mode line changes when a window becomes in-/active.")
           (base32 "10gkg7jh1s1484gm66a87zr7x8vmv00s7gfd0w2pj47nqf98g8hz"))))
       (build-system emacs-build-system)
       (arguments
-       `(
-         ;; Include Pywal interaction scripts.
-         #:include (cons "^python/" %default-include)
-         #:phases
-         (modify-phases %standard-phases
-           (add-after 'unpack 'patch-exec-paths
-             (lambda* (#:key inputs #:allow-other-keys)
-               (let ((files '("theme-magic.el" "python/wal_change_colors.py"))
-                     (python (assoc-ref inputs "python"))
-                     (python-pywal (assoc-ref inputs "python-pywal")))
-                 (substitute* files
-                   (("\"python\"") (string-append "\"" python "/bin/python3\""))
-                   (("\"wal\"") (string-append "\"" python-pywal "/bin/wal\""))))
-               #t)))))
+       (list
+        ;; Include Pywal interaction scripts.
+        #:include #~(cons "^python/" %default-include)
+        #:phases
+        #~(modify-phases %standard-phases
+            (add-after 'unpack 'patch-exec-paths
+              (lambda* (#:key inputs #:allow-other-keys)
+                (substitute* '("theme-magic.el" "python/wal_change_colors.py")
+                  (("\"python\"")
+                   (string-append "\""
+                                  (search-input-file inputs "/bin/python3")
+                                  "\""))
+                  (("\"wal\"")
+                   (string-append "\""
+                                  (search-input-file inputs "/bin/wal")
+                                  "\""))))))))
       (inputs
        (list python python-pywal))
       (home-page "https://github.com/jcaw/theme-magic")