summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-09-14 22:04:50 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-09-14 22:04:50 +0300
commit6ea541e016706568538c9ca842211c74a70927b8 (patch)
tree71b84bd002223e1287df806d5aa0b3140ece094d /gnu
parent7ddacf88ef893856b920c52c65bc81689fc277b8 (diff)
downloadguix-6ea541e016706568538c9ca842211c74a70927b8.tar.gz
gnu: links: Use 'modify-phases'.
* gnu/packages/links.scm (links)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/links.scm34
1 files changed, 17 insertions, 17 deletions
diff --git a/gnu/packages/links.scm b/gnu/packages/links.scm
index c741f2d55c..2f0c12a786 100644
--- a/gnu/packages/links.scm
+++ b/gnu/packages/links.scm
@@ -42,23 +42,23 @@
                (base32 "01a4mbpvf7450ymqarjkpmzrm0z2zyd9lvqwg7x9kcd36i9hjln2"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases (alist-replace
-                 'configure
-                 (lambda* (#:key outputs #:allow-other-keys)
-                   ;; The tarball uses a very old version of autconf. It doesn't
-                   ;; understand extra flags like `--enable-fast-install', so
-                   ;; we need to invoke it with just what it understands.
-                   (let ((out (assoc-ref outputs "out")))
-                     ;; 'configure' doesn't understand '--host'.
-                     ,@(if (%current-target-system)
-                           `((setenv "CHOST" ,(%current-target-system)))
-                           '())
-                     (setenv "CONFIG_SHELL" (which "bash"))
-                     (zero?
-                      (system* "./configure"
-                               (string-append "--prefix=" out)
-                               "--enable-graphics"))))
-                 %standard-phases)))
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'configure
+           (lambda* (#:key outputs #:allow-other-keys)
+             ;; The tarball uses a very old version of autconf. It doesn't
+             ;; understand extra flags like `--enable-fast-install', so
+             ;; we need to invoke it with just what it understands.
+             (let ((out (assoc-ref outputs "out")))
+               ;; 'configure' doesn't understand '--host'.
+               ,@(if (%current-target-system)
+                     `((setenv "CHOST" ,(%current-target-system)))
+                     '())
+               (setenv "CONFIG_SHELL" (which "bash"))
+               (zero?
+                (system* "./configure"
+                         (string-append "--prefix=" out)
+                         "--enable-graphics"))))))))
     (native-inputs `(("pkg-config" ,pkg-config)))
     (inputs `(("zlib" ,zlib)
               ("openssl" ,openssl)