summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-10-15 23:37:28 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-10-16 02:03:27 +0200
commit6f19c32b0eeeb6b6647ef75c4c8b9e390d41fcd9 (patch)
tree65bd983ab024157e47f95f59cea330a9d8a4e62c /gnu
parent6688aed40869567ef0d37a5165e7870afea87087 (diff)
downloadguix-6f19c32b0eeeb6b6647ef75c4c8b9e390d41fcd9.tar.gz
gnu: dmidecode: Update to 3.3.
* gnu/packages/admin.scm (dmidecode): Update to 3.3.
[arguments]: Restructure.  Add CC to #:make-flags.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/admin.scm29
1 files changed, 16 insertions, 13 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 1b80eb8ab7..93430dceb7 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1809,21 +1809,24 @@ network, which causes enabled computers to power on.")
 (define-public dmidecode
   (package
     (name "dmidecode")
-    (version "3.2")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "mirror://savannah/dmidecode/dmidecode-"
-                    version ".tar.xz"))
-              (sha256
-               (base32
-                "1pcfhcgs2ifdjwp7amnsr3lq95pgxpr150bjhdinvl505px0cw07"))))
+    (version "3.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://savannah/dmidecode/dmidecode-"
+                           version ".tar.xz"))
+       (sha256
+        (base32 "0m8lzg9rf1qssasiix672bxk5qwms90561g8hfkkhk31h2kkgiw2"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases (modify-phases %standard-phases (delete 'configure))
-       #:tests? #f                                ; no 'check' target
-       #:make-flags (list (string-append "prefix="
-                                         (assoc-ref %outputs "out")))))
+     `(#:tests? #f                                ; no 'check' target
+       #:make-flags
+       (list (string-append "CC=" ,(cc-for-target))
+             (string-append "prefix="
+                            (assoc-ref %outputs "out")))
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure))))                   ; no configure script
     (home-page "https://www.nongnu.org/dmidecode/")
     (synopsis "Read hardware information from the BIOS")
     (description