summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-13 00:34:05 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:39 +0200
commit7af4d29ace7d10f1a7ab083a3ec84758a00924fb (patch)
treed89540902e81706ad845ef9f3e9a0197a4c12062 /gnu
parente1e0e08451e84ccb7530e5a8187367333f1f87ee (diff)
downloadguix-7af4d29ace7d10f1a7ab083a3ec84758a00924fb.tar.gz
gnu: texlive-latex-psfrag -> texlive-psfrag.
* gnu/packages/tex.scm (texlive-psfrag): New variable.
(texlive-latex-psfrag): Deprecate variable.
(texlive-pstool):
* gnu/packages/bioinformatics.scm (phyml): Use new name.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm2
-rw-r--r--gnu/packages/tex.scm35
2 files changed, 21 insertions, 16 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index eab2b24ab1..22d2722538 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -12111,7 +12111,7 @@ programs for inferring phylogenies (evolutionary trees).")
                                      texlive-graphics
                                      texlive-grfext
                                      texlive-hyperref
-                                     texlive-latex-psfrag
+                                     texlive-psfrag
                                      texlive-xcolor))))
     (home-page "https://github.com/stephaneguindon/phyml")
     (synopsis "Programs for working on SAM/BAM files")
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4c78950cca..d10c67620c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5451,31 +5451,36 @@ available for LuaTeX by reimplementing them using Lua.")
 
 (define-deprecated-package texlive-latex-pdftexcmds texlive-pdftexcmds)
 
-(define-public texlive-latex-psfrag
+(define-public texlive-psfrag
   (package
-    (name "texlive-latex-psfrag")
+    (name "texlive-psfrag")
     (version (number->string %texlive-revision))
-    (source (origin
-              (method svn-fetch)
-              (uri (texlive-ref "latex" "psfrag"))
-              (file-name (string-append name "-" version "-checkout"))
-              (sha256
-               (base32
-                "1dxbl5il7wbbsp0v45vk884xi1192wxw03849pb1g5q4x808n352"))))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/psfrag/"
+                   "dvips/psfrag/"
+                   "source/latex/psfrag/"
+                   "tex/latex/psfrag/")
+             (base32
+              "06vp5x6rnl4gqwxzzynbl169q23k8pmaxjhb0lbzdcm3ihvzp47z")))
+    (outputs '("out" "doc"))
     (build-system texlive-build-system)
-    (arguments '(#:tex-directory "latex/psfrag"))
-    (home-page "https://www.ctan.org/pkg/psfrag")
+    (propagated-inputs
+     (list texlive-graphics))
+    (home-page "https://ctan.org/pkg/psfrag")
     (synopsis "Replace strings in encapsulated PostScript figures")
     (description
      "This package allows LaTeX constructions (equations, picture
 environments, etc.) to be precisely superimposed over Encapsulated PostScript
 figures, using your own favorite drawing tool to create an EPS figure and
-placing simple text \"tags\" where each replacement is to be placed, with
-PSfrag automatically removing these tags from the figure and replacing them
-with a user specified LaTeX construction, properly aligned, scaled, and/or
+placing simple text tags where each replacement is to be placed, with PSfrag
+automatically removing these tags from the figure and replacing them with
+a user specified LaTeX construction, properly aligned, scaled, and/or
 rotated.")
     (license (license:fsf-free "file://psfrag.dtx"))))
 
+(define-deprecated-package texlive-latex-psfrag texlive-psfrag)
+
 (define-public texlive-pstool
   (package
     (inherit (simple-texlive-package
@@ -5492,7 +5497,7 @@ rotated.")
            texlive-ifplatform
            texlive-l3kernel ; for expl3
            texlive-oberdiek
-           texlive-latex-psfrag
+           texlive-psfrag
            texlive-tools                ; for shellesc
            texlive-trimspaces
            texlive-latex-xkeyval))