summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2022-01-18 13:56:17 +0100
committerLars-Dominik Braun <lars@6xq.net>2022-01-18 14:19:42 +0100
commit80db7ab65bbcb2465e7aebbb9bece4af2293fe78 (patch)
treec6ee656f05b640e4ddbf8d360db5c0c897356b58 /gnu
parent9350538558a35eedb112b61a528ccee857738fc9 (diff)
downloadguix-80db7ab65bbcb2465e7aebbb9bece4af2293fe78.tar.gz
gnu: Add python-reedsolo.
Missing dependency of python-esptool.

* gnu/packages/python-xyz.scm (python-reedsolo): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e4cb94fe1b..edb2937c5f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28593,3 +28593,23 @@ to:
 it supports reStructuredText, Markdown, IPython (Jupyter) Notebooks and HTML,
 and has plugins for many other formats.")
     (license license:expat)))
+
+(define-public python-reedsolo
+  (package
+    (name "python-reedsolo")
+    (version "1.5.4")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "reedsolo" version))
+        (sha256
+          (base32 "09q15ji9iac3nmmxrcdvz8ynldvvqanqy3hs6q3cp327hgf5rcmq"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/tomerfiliba/reedsolomon")
+    (synopsis "Pure-Python Reed Solomon encoder/decoder")
+    (description "A pure-python universal errors-and-erasures Reed-Solomon
+Codec, based on the tutorial at Wikiversity.  This is a burst-type
+implementation, so that it supports any Galois field higher than 2^3,
+but not binary streams.")
+    (license license:public-domain)))
+